summaryrefslogtreecommitdiff
path: root/meta-intel-openbmc/meta-common/recipes-core
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@intel.com>2022-02-17 02:13:43 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-02-17 17:04:39 +0300
commitd009b4d9d61aefca1ea30f8aa51a432ca0bb973b (patch)
treeecd2e6980a88618e37962ccb8888244e628b8568 /meta-intel-openbmc/meta-common/recipes-core
parent686abc91115fb538cedf52204ee0558c340504fa (diff)
downloadopenbmc-d009b4d9d61aefca1ea30f8aa51a432ca0bb973b.tar.xz
meta-intel-openbmc: Use '=' with remove
Yocto has started throwing WARNINGs about using 'remove' with '+=': WARNING: ...:remove += is not a recommended operator combination, please replace it. This changes the '+=' in those cases to '='. Tested: confirmed that it builds without these warnings Signed-off-by: Jason M. Bills <jason.m.bills@intel.com> Change-Id: I54377229cd05bcb89f4c5edbb303dcc54e629192
Diffstat (limited to 'meta-intel-openbmc/meta-common/recipes-core')
-rw-r--r--meta-intel-openbmc/meta-common/recipes-core/systemd/obmc-targets.bbappend16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta-intel-openbmc/meta-common/recipes-core/systemd/obmc-targets.bbappend b/meta-intel-openbmc/meta-common/recipes-core/systemd/obmc-targets.bbappend
index 6f19a5e903..edf0986095 100644
--- a/meta-intel-openbmc/meta-common/recipes-core/systemd/obmc-targets.bbappend
+++ b/meta-intel-openbmc/meta-common/recipes-core/systemd/obmc-targets.bbappend
@@ -1,9 +1,9 @@
# Remove these files since they are provided by obmc-intel-targets
-SYSTEMD_SERVICE:${PN}:remove:intel += " obmc-host-start@.target"
-SYSTEMD_SERVICE:${PN}:remove:intel += " obmc-host-stop@.target"
-SYSTEMD_SERVICE:${PN}:remove:intel += " obmc-host-reboot@.target"
-SYSTEMD_SERVICE:${PN}:remove:intel += " obmc-host-startmin@.target"
-SYSTEMD_SERVICE:${PN}:remove:intel += " obmc-chassis-poweron@.target"
-SYSTEMD_SERVICE:${PN}:remove:intel += " obmc-chassis-poweroff@.target"
-SYSTEMD_SERVICE:${PN}:remove:intel += " obmc-chassis-hard-poweroff@.target"
-SYSTEMD_SERVICE:${PN}:remove:intel += " obmc-chassis-powerreset@.target"
+SYSTEMD_SERVICE:${PN}:remove:intel = " obmc-host-start@.target"
+SYSTEMD_SERVICE:${PN}:remove:intel = " obmc-host-stop@.target"
+SYSTEMD_SERVICE:${PN}:remove:intel = " obmc-host-reboot@.target"
+SYSTEMD_SERVICE:${PN}:remove:intel = " obmc-host-startmin@.target"
+SYSTEMD_SERVICE:${PN}:remove:intel = " obmc-chassis-poweron@.target"
+SYSTEMD_SERVICE:${PN}:remove:intel = " obmc-chassis-poweroff@.target"
+SYSTEMD_SERVICE:${PN}:remove:intel = " obmc-chassis-hard-poweroff@.target"
+SYSTEMD_SERVICE:${PN}:remove:intel = " obmc-chassis-powerreset@.target"