summaryrefslogtreecommitdiff
path: root/meta-nuvoton/recipes-bsp/images/npcm7xx-bingo-native_git.bb
diff options
context:
space:
mode:
authorBenjamin Fair <benjaminfair@google.com>2019-09-16 21:32:43 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-17 14:21:20 +0300
commite43b2038ebe7157d62bd270890f9dd81abaace3b (patch)
tree3339db95b998a86c1056e335c6201e86653e398a /meta-nuvoton/recipes-bsp/images/npcm7xx-bingo-native_git.bb
parent136ad773f3799a28d3e96cc01c2555357bb44676 (diff)
downloadopenbmc-e43b2038ebe7157d62bd270890f9dd81abaace3b.tar.xz
meta-nuvoton: images: fixup bingo and bootblock recipes
Add version information and descriptions to the two recipe files. (From meta-nuvoton rev: b5087ace68e81084e16075e76659ca5a6f553994) Change-Id: I52db4fc4193999b01a4a17e78d9060ef93eab944 Signed-off-by: Benjamin Fair <benjaminfair@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-nuvoton/recipes-bsp/images/npcm7xx-bingo-native_git.bb')
-rw-r--r--meta-nuvoton/recipes-bsp/images/npcm7xx-bingo-native_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-nuvoton/recipes-bsp/images/npcm7xx-bingo-native_git.bb b/meta-nuvoton/recipes-bsp/images/npcm7xx-bingo-native_git.bb
new file mode 100644
index 0000000000..5ab1fc9424
--- /dev/null
+++ b/meta-nuvoton/recipes-bsp/images/npcm7xx-bingo-native_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "XML-based binary image generator"
+DESCRIPTION = "XML-based binary image generator"
+HOMEPAGE = "https://github.com/Nuvoton-Israel/bingo"
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI += "git://github.com/Nuvoton-Israel/bingo"
+SRC_URI += "file://BootBlockAndHeader_EB.xml"
+SRC_URI += "file://UbootHeader_EB.xml"
+SRC_URI += "file://mergedBootBlockAndUboot.xml"
+
+SRCREV = "4f102ff7851da9fd11965857edd1b3046c187b7a"
+
+S = "${WORKDIR}/git"
+
+do_install () {
+
+ install -d "${D}${bindir}"
+ install deliverables/linux/Release/bingo ${D}${bindir}
+ install ${WORKDIR}/*.xml ${D}${bindir}
+}
+
+inherit native