summaryrefslogtreecommitdiff
path: root/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.10.17.bb
diff options
context:
space:
mode:
authorGeorge Hung <george.hung@quantatw.com>2021-04-22 03:47:52 +0300
committerGeorge Hung <george.hung@quantatw.com>2021-04-22 03:47:52 +0300
commit01eac59fbe806a32ab857dbceb69b8ede949e724 (patch)
tree03f78727dcb8464d476944fc3adfad457c89c8f4 /meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.10.17.bb
parentf87c9e5f3539d207d727a2e2d4ffe39afc86fd91 (diff)
downloadopenbmc-01eac59fbe806a32ab857dbceb69b8ede949e724.tar.xz
meta-nuvoton: npcm7xx-bootblock: upgrade to 10.10.17
Changes: - Add retries to DDR training. - Disable MC ECC interrupts. - Add memory tests at the end of the DDR training. Signed-off-by: George Hung <george.hung@quantatw.com> Change-Id: If05c27e7f1f5e6dec529accb3d67f0b8017756c2
Diffstat (limited to 'meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.10.17.bb')
-rw-r--r--meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.10.17.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.10.17.bb b/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.10.17.bb
new file mode 100644
index 0000000000..7e1912d22a
--- /dev/null
+++ b/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.10.17.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Primary bootloader for NPCM7XX (Poleg) devices"
+DESCRIPTION = "Primary bootloader for NPCM7XX (Poleg) devices"
+HOMEPAGE = "https://github.com/Nuvoton-Israel/npcm7xx-bootblock"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+FILENAME = "Poleg_bootblock_${PV}.bin"
+
+S = "${WORKDIR}"
+
+SRCREV = "7bfef99f7a0354395519c4975f96d66cdda1fb67"
+SRC_URI = " \
+ https://raw.githubusercontent.com/Nuvoton-Israel/bootblock/${SRCREV}/LICENSE;name=lic \
+ https://github.com/Nuvoton-Israel/bootblock/releases/download/BootBlock_${PV}/Poleg_bootblock_basic.bin;downloadfilename=${FILENAME};name=bin \
+"
+
+SRC_URI[lic.md5sum] = "b234ee4d69f5fce4486a80fdaf4a4263"
+SRC_URI[bin.sha256sum] = "3e92e3f6c4624139d000f91541792a54f52205637bb88abd14310c854694cb39"
+
+inherit deploy
+
+do_deploy () {
+ install -D -m 644 ${WORKDIR}/${FILENAME} ${DEPLOYDIR}/Poleg_bootblock.bin
+}
+
+addtask deploy before do_build after do_compile