summaryrefslogtreecommitdiff
path: root/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.10.19.bb
diff options
context:
space:
mode:
authorTim Lee <timlee660101@gmail.com>2024-04-17 12:24:09 +0300
committerTim Lee <chli30@nuvoton.com>2024-04-25 05:14:52 +0300
commit4aa1593e04a9489e26e82c26e40ad99be4b1cbfe (patch)
tree79f7f8a05ae025c926c198b15a8247fbcf022f55 /meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.10.19.bb
parent77f78cae511edd3d0a6554607c3a419cac627b94 (diff)
downloadopenbmc-4aa1593e04a9489e26e82c26e40ad99be4b1cbfe.tar.xz
meta-nuvoton: npcm7xx-bootblock: upgrade to 10.10.19
Changelog: version 10.10.19 - Mar 27th 2024 ============= - U-Boot can only be loaded to DRAM from the range 0x100 till end of DRAM. - Avoid TOCTOU: read destination address and size only once. - Remove XIP. Signed-off-by: Tim Lee <timlee660101@gmail.com> Change-Id: Icd56348f9f2818fb381b91ddbc3fc3e566a9da87
Diffstat (limited to 'meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.10.19.bb')
-rw-r--r--meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.10.19.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.10.19.bb b/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.10.19.bb
new file mode 100644
index 0000000000..db6c08a22d
--- /dev/null
+++ b/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.10.19.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Primary bootloader for NPCM7XX (Poleg) devices"
+DESCRIPTION = "Primary bootloader for NPCM7XX (Poleg) devices"
+HOMEPAGE = "https://github.com/Nuvoton-Israel/npcm7xx-bootblock"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+FILENAME = "Poleg_bootblock_${PV}.bin"
+
+S = "${WORKDIR}"
+
+SRCREV = "cac8f0ed8c6e875148ec37b657fcbdd1058c2c69"
+SRC_URI = " \
+ https://raw.githubusercontent.com/Nuvoton-Israel/bootblock/${SRCREV}/LICENSE;name=lic \
+ https://github.com/Nuvoton-Israel/bootblock/releases/download/BootBlock_${PV}/Poleg_bootblock_basic.bin;downloadfilename=${FILENAME};name=bin \
+"
+
+SRC_URI[lic.md5sum] = "b234ee4d69f5fce4486a80fdaf4a4263"
+SRC_URI[bin.sha256sum] = "1bc367032b2ac76190064256a306993a0405de2a2af5b4fad2c549ccd6a0ba0f"
+
+inherit deploy
+
+do_deploy () {
+ install -D -m 644 ${WORKDIR}/${FILENAME} ${DEPLOYDIR}/Poleg_bootblock.bin
+}
+
+addtask deploy before do_build after do_compile