summaryrefslogtreecommitdiff
path: root/meta-nuvoton/recipes-bsp/images
diff options
context:
space:
mode:
authorTim Lee <timlee660101@gmail.com>2023-05-23 05:19:18 +0300
committerTim Lee <chli30@nuvoton.com>2023-05-28 13:48:14 +0300
commitfedbc0b4f600975c065b8d083d3e7369715b4e29 (patch)
tree553d4aa17bc389eeba9bb00a50562e631440cd21 /meta-nuvoton/recipes-bsp/images
parentf2ec54b184f105e99f375ce5e1f53ae688244a22 (diff)
downloadopenbmc-fedbc0b4f600975c065b8d083d3e7369715b4e29.tar.xz
meta-nuvoton: npcm8xx-igps: update to 03.09.00
Changelog: IGPS 03.09.00 - May 18th 2023 ============== - TIP_FW 0.5.9 L0 0.4.8 L1 - Bootblock version 0.3.2 - skip clearing INTCR2 - SCRPAD 10 is now reset - split CRC file (tip\notip) - Clear SCRPAD10-19 - Add BootBlockAndHeader_A1_EB_NoTip.xml for EB IGPS 03.08.09 - May 14th 2023 ============== - TIP_FW 0.5.9 L0 0.4.8 L1 - Bootblock version 0.3.1 - Added code for A2 - flash: support flash size mix - restore: force main and recovery flashes to the same - Add timestamp compare to combo IGPS 03.08.08 - May 3rd 2023 ============== - TIP_FW 0.5.7 L0 0.4.6 L1 - Bootblock version 0.3.0 - Added support for no TIP mode - No TIP mode is only for A2 users - IGPS still supports TIP mode IGPS 03.08.07 - April 17th 2023 ============== - TIP_FW 0.5.7 L0 0.4.6 L1 - Bootblock version 0.2.9 - Support A2 Signed-off-by: Tim Lee <timlee660101@gmail.com> Change-Id: I2a2902f0ba07ad2ab2002357c8e5a4a228ed311a
Diffstat (limited to 'meta-nuvoton/recipes-bsp/images')
-rw-r--r--meta-nuvoton/recipes-bsp/images/npcm8xx-bootblock.inc16
-rw-r--r--meta-nuvoton/recipes-bsp/images/npcm8xx-bootblock_0.2.8.bb6
-rw-r--r--meta-nuvoton/recipes-bsp/images/npcm8xx-bootblock_0.3.2.bb3
-rw-r--r--meta-nuvoton/recipes-bsp/images/npcm8xx-igps-native_03.08.06.bb4
-rw-r--r--meta-nuvoton/recipes-bsp/images/npcm8xx-igps-native_03.09.00.bb4
-rw-r--r--meta-nuvoton/recipes-bsp/images/npcm8xx-igps.inc6
-rw-r--r--meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw_0.5.9.0.4.8.bb (renamed from meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw_0.5.6.0.4.5.bb)2
7 files changed, 24 insertions, 17 deletions
diff --git a/meta-nuvoton/recipes-bsp/images/npcm8xx-bootblock.inc b/meta-nuvoton/recipes-bsp/images/npcm8xx-bootblock.inc
index b4a5464f00..71e22251b4 100644
--- a/meta-nuvoton/recipes-bsp/images/npcm8xx-bootblock.inc
+++ b/meta-nuvoton/recipes-bsp/images/npcm8xx-bootblock.inc
@@ -4,19 +4,25 @@ HOMEPAGE = "https://github.com/Nuvoton-Israel/npcm8xx-bootblock"
LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-FILENAME = "arbel_a35_bootblock_${PV}.bin"
+BB_TIP = "arbel_a35_bootblock.bin"
+BB_NO_TIP = "arbel_a35_bootblock_no_tip.bin"
+
+OUTPUT_BB_TIP_BIN = "Images/tip"
+OUTPUT_BB_NO_TIP_BIN = "Images/no_tip"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/Nuvoton-Israel/npcm8xx-bootblock;branch=main;protocol=https \
- https://github.com/Nuvoton-Israel/npcm8xx-bootblock/releases/download/${RELEASE}/arbel_a35_bootblock.${PV}.bin;downloadfilename=${FILENAME};name=bin \
-"
+ git://github.com/Nuvoton-Israel/npcm8xx-bootblock;branch=main;protocol=https"
inherit deploy
do_deploy () {
- install -D -m 644 ${WORKDIR}/${FILENAME} ${DEPLOYDIR}/arbel_a35_bootblock.bin
+ if [ "${TIP_IMAGE}" = "True" ] ; then
+ install -D -m 644 ${OUTPUT_BB_TIP_BIN}/${BB_TIP} ${DEPLOYDIR}/${BB_TIP}
+ else
+ install -D -m 644 ${OUTPUT_BB_NO_TIP_BIN}/${BB_NO_TIP} ${DEPLOYDIR}/${BB_NO_TIP}
+ fi
}
addtask deploy before do_build after do_compile
diff --git a/meta-nuvoton/recipes-bsp/images/npcm8xx-bootblock_0.2.8.bb b/meta-nuvoton/recipes-bsp/images/npcm8xx-bootblock_0.2.8.bb
deleted file mode 100644
index 9ef8e656a5..0000000000
--- a/meta-nuvoton/recipes-bsp/images/npcm8xx-bootblock_0.2.8.bb
+++ /dev/null
@@ -1,6 +0,0 @@
-SRCREV = "4002b2f086f6d2177ec36bed507241386d604f6b"
-RELEASE = "A35_BootBlock_0.2.8"
-
-SRC_URI[bin.sha256sum] = "164c5e57d02accd61c14b6e13dff3dbbbe1d64375ca6ee97da50b9850dfb7f49"
-
-require npcm8xx-bootblock.inc
diff --git a/meta-nuvoton/recipes-bsp/images/npcm8xx-bootblock_0.3.2.bb b/meta-nuvoton/recipes-bsp/images/npcm8xx-bootblock_0.3.2.bb
new file mode 100644
index 0000000000..8ff12b6f6e
--- /dev/null
+++ b/meta-nuvoton/recipes-bsp/images/npcm8xx-bootblock_0.3.2.bb
@@ -0,0 +1,3 @@
+SRCREV = "4a0758cf7c2ea1505e648346a7a407c3974467a7"
+
+require npcm8xx-bootblock.inc
diff --git a/meta-nuvoton/recipes-bsp/images/npcm8xx-igps-native_03.08.06.bb b/meta-nuvoton/recipes-bsp/images/npcm8xx-igps-native_03.08.06.bb
deleted file mode 100644
index c39f216b33..0000000000
--- a/meta-nuvoton/recipes-bsp/images/npcm8xx-igps-native_03.08.06.bb
+++ /dev/null
@@ -1,4 +0,0 @@
-# tag IGPS_03.08.06
-SRCREV = "96bba1f416dfc206be6d0cd9f224446cf21fd7a0"
-
-require npcm8xx-igps.inc
diff --git a/meta-nuvoton/recipes-bsp/images/npcm8xx-igps-native_03.09.00.bb b/meta-nuvoton/recipes-bsp/images/npcm8xx-igps-native_03.09.00.bb
new file mode 100644
index 0000000000..2ec0ea5f06
--- /dev/null
+++ b/meta-nuvoton/recipes-bsp/images/npcm8xx-igps-native_03.09.00.bb
@@ -0,0 +1,4 @@
+# tag IGPS_03.09.00
+SRCREV = "30086cd06bee63c5715622a624620c30ade6652e"
+
+require npcm8xx-igps.inc
diff --git a/meta-nuvoton/recipes-bsp/images/npcm8xx-igps.inc b/meta-nuvoton/recipes-bsp/images/npcm8xx-igps.inc
index 3906a8c738..ace078e61a 100644
--- a/meta-nuvoton/recipes-bsp/images/npcm8xx-igps.inc
+++ b/meta-nuvoton/recipes-bsp/images/npcm8xx-igps.inc
@@ -21,7 +21,11 @@ do_patch() {
do_install() {
install -d ${DEST}
- install py_scripts/ImageGeneration/references/BootBlockAndHeader_${DEVICE_GEN}_${IGPS_MACHINE}.xml ${DEST}
+ if [ "${TIP_IMAGE}" = "True" ] ; then
+ install py_scripts/ImageGeneration/references/BootBlockAndHeader_${DEVICE_GEN}_${IGPS_MACHINE}.xml ${DEST}
+ else
+ install py_scripts/ImageGeneration/references/BootBlockAndHeader_A1_${IGPS_MACHINE}_NoTip.xml ${DEST}
+ fi
install py_scripts/ImageGeneration/references/UbootHeader_${DEVICE_GEN}.xml ${DEST}
install py_scripts/ImageGeneration/inputs/BL31_AndHeader.xml ${DEST}
install py_scripts/ImageGeneration/inputs/OpTeeAndHeader.xml ${DEST}
diff --git a/meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw_0.5.6.0.4.5.bb b/meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw_0.5.9.0.4.8.bb
index d6ac402a53..e5615de7a5 100644
--- a/meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw_0.5.6.0.4.5.bb
+++ b/meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw_0.5.9.0.4.8.bb
@@ -1,4 +1,4 @@
-SRCREV = "e77ac50935dc20e042ac96f932ae2629d655b068"
+SRCREV = "1429f76f2cb4fb073693cbf9e696d9f61d02c509"
OUTPUT_BIN = "output_binaries_${DEVICE_GEN}_${IGPS_MACHINE}"