summaryrefslogtreecommitdiff
path: root/meta-nuvoton/recipes-bsp
diff options
context:
space:
mode:
authorBrian Ma <chma0@nuvoton.com>2023-05-11 12:12:43 +0300
committerBrian Ma <chma0@nuvoton.com>2023-07-04 08:36:26 +0300
commit2a1e461a98a74229bab8decf68b9d79bb1555253 (patch)
tree9cfa7e90c070a7db15a1c89bc475c7b9db1b8e5a /meta-nuvoton/recipes-bsp
parent28b59de8c0e2391e663d40bda31604e75fddd68f (diff)
downloadopenbmc-2a1e461a98a74229bab8decf68b9d79bb1555253.tar.xz
meta-nuvoton: Update default fw_env.config
Update new fw_env.config for U-Boot fw_print/setenv utils access correct U-Boot environment offset. And also add recipe udev-nuvoton-mtd-partitions for create readable mtd device symlink. Change-Id: I3bfa2015f536b27382f561bd8cdb0d7dbd2d88cd Signed-off-by: Brian Ma <chma0@nuvoton.com>
Diffstat (limited to 'meta-nuvoton/recipes-bsp')
-rw-r--r--meta-nuvoton/recipes-bsp/u-boot/files/fw_env.config2
-rw-r--r--meta-nuvoton/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_git.bb4
2 files changed, 5 insertions, 1 deletions
diff --git a/meta-nuvoton/recipes-bsp/u-boot/files/fw_env.config b/meta-nuvoton/recipes-bsp/u-boot/files/fw_env.config
new file mode 100644
index 0000000000..8bd3ae7bff
--- /dev/null
+++ b/meta-nuvoton/recipes-bsp/u-boot/files/fw_env.config
@@ -0,0 +1,2 @@
+# MTD device name Device offset Env. size Flash sector size Number of sectors
+/dev/mtd/u-boot-env 0x0000 0x40000 0x4000
diff --git a/meta-nuvoton/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_git.bb b/meta-nuvoton/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_git.bb
index 4ccfdd1d8c..029b436e9a 100644
--- a/meta-nuvoton/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_git.bb
+++ b/meta-nuvoton/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_git.bb
@@ -2,8 +2,10 @@ require u-boot-common-nuvoton.inc
SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
DEPENDS = "mtd-utils bison-native"
+RDEPENDS:${PN} = "udev-nuvoton-mtd-partitions"
PROVIDES += "u-boot-fw-utils"
+SRC_URI += "file://fw_env.config"
INSANE_SKIP:${PN} = "already-stripped"
@@ -22,7 +24,7 @@ do_install () {
install -d ${D}${sysconfdir}
install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
- install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
+ install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
}
do_install:class-cross () {