summaryrefslogtreecommitdiff
path: root/meta-nuvoton
diff options
context:
space:
mode:
authorTim Lee <timlee660101@gmail.com>2022-11-07 04:47:20 +0300
committerTim Lee <chli30@nuvoton.com>2022-12-01 03:57:49 +0300
commit7e9914fc5f22cb5062483bbc515a454dcad1525d (patch)
treec87b86fa4d944c88e6cf7ce361175d7041286126 /meta-nuvoton
parentd16ad2da7f3d54e1a2048c20c3c63ad90bc2cb73 (diff)
downloadopenbmc-7e9914fc5f22cb5062483bbc515a454dcad1525d.tar.xz
meta-nuvoton: move npcm8xx-bootblock recipe into inc file
Follow the other npcm8xx recipes to use different versions of this recipe for different platforms. Tested: build pass and boot up successfully with correct bootblock version. Signed-off-by: Tim Lee <timlee660101@gmail.com> Change-Id: Ic97de46876e7e821b65515846d40c939d273bcc1
Diffstat (limited to 'meta-nuvoton')
-rw-r--r--meta-nuvoton/recipes-bsp/images/npcm8xx-bootblock.inc25
-rw-r--r--meta-nuvoton/recipes-bsp/images/npcm8xx-bootblock_0.2.3.bb24
2 files changed, 27 insertions, 22 deletions
diff --git a/meta-nuvoton/recipes-bsp/images/npcm8xx-bootblock.inc b/meta-nuvoton/recipes-bsp/images/npcm8xx-bootblock.inc
new file mode 100644
index 0000000000..6910fc9c53
--- /dev/null
+++ b/meta-nuvoton/recipes-bsp/images/npcm8xx-bootblock.inc
@@ -0,0 +1,25 @@
+SUMMARY = "Primary bootloader for NPCM8XX (Arbel) devices"
+DESCRIPTION = "Primary bootloader for NPCM8XX (Arbel) devices"
+HOMEPAGE = "https://github.com/Nuvoton-Israel/npcm8xx-bootblock"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=650b869bd8ff2aed59c62bad2a22a821"
+
+FILENAME = "arbel_a35_bootblock_${PV}.bin"
+
+S = "${WORKDIR}"
+
+SRC_URI = " \
+ https://github.com/Nuvoton-Israel/npcm8xx-bootblock/blob/${SRCREV}/LICENSE;name=lic \
+ https://github.com/Nuvoton-Israel/npcm8xx-bootblock/releases/download/${RELEASE}/arbel_a35_bootblock.bin;downloadfilename=${FILENAME};name=bin \
+"
+
+SRC_URI[lic.sha256sum] = "7c34d28e784b202aa4998f477fd0aa9773146952d7f6fa5971369fcdda59cf48"
+
+inherit deploy
+
+do_deploy () {
+ install -D -m 644 ${WORKDIR}/${FILENAME} ${DEPLOYDIR}/arbel_a35_bootblock.bin
+}
+
+addtask deploy before do_build after do_compile
+
diff --git a/meta-nuvoton/recipes-bsp/images/npcm8xx-bootblock_0.2.3.bb b/meta-nuvoton/recipes-bsp/images/npcm8xx-bootblock_0.2.3.bb
index fac6518c59..3331842a30 100644
--- a/meta-nuvoton/recipes-bsp/images/npcm8xx-bootblock_0.2.3.bb
+++ b/meta-nuvoton/recipes-bsp/images/npcm8xx-bootblock_0.2.3.bb
@@ -1,26 +1,6 @@
-SUMMARY = "Primary bootloader for NPCM8XX (Arbel) devices"
-DESCRIPTION = "Primary bootloader for NPCM8XX (Arbel) devices"
-HOMEPAGE = "https://github.com/Nuvoton-Israel/npcm8xx-bootblock"
-LICENSE = "GPL-2.0-only"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=650b869bd8ff2aed59c62bad2a22a821"
-
-FILENAME = "arbel_a35_bootblock_${PV}.bin"
-
-S = "${WORKDIR}"
-
SRCREV = "4002b2f086f6d2177ec36bed507241386d604f6b"
-SRC_URI = " \
- https://github.com/Nuvoton-Israel/npcm8xx-bootblock/blob/${SRCREV}/LICENSE;name=lic \
- https://github.com/Nuvoton-Israel/npcm8xx-bootblock/releases/download/A35_BootBlock_${PV}/arbel_a35_bootblock.bin;downloadfilename=${FILENAME};name=bin \
-"
+RELEASE = "A35_BootBlock_0.2.3"
-SRC_URI[lic.sha256sum] = "7c34d28e784b202aa4998f477fd0aa9773146952d7f6fa5971369fcdda59cf48"
SRC_URI[bin.sha256sum] = "9d58a1dbe2ee156780b53f2539cf5d48436a83390ad9db340acc503aef7de72d"
-inherit deploy
-
-do_deploy () {
- install -D -m 644 ${WORKDIR}/${FILENAME} ${DEPLOYDIR}/arbel_a35_bootblock.bin
-}
-
-addtask deploy before do_build after do_compile
+require npcm8xx-bootblock.inc