summaryrefslogtreecommitdiff
path: root/meta-openbmc-machines
diff options
context:
space:
mode:
authorLei YU <mine260309@gmail.com>2017-04-05 10:47:09 +0300
committerPatrick Williams <patrick@stwcx.xyz>2017-04-09 14:56:12 +0300
commit15efd330b2b4f1a2afeb5de069be9714711b3158 (patch)
tree8174447e6833df7050434fb208f41f8786dc76ed /meta-openbmc-machines
parent8f8ae9d7d5031d79bdb732d26539049211fbec9d (diff)
downloadopenbmc-15efd330b2b4f1a2afeb5de069be9714711b3158.tar.xz
meta-romulus: Re-order service units for power on
After OpenFSI driver is integrated, vcs_workaround now depends on fsi_scan service, which depends on PGOOD. Romulus previous vcs_workaround is run after CPLD gives power and before PGOOD is asserted, and thus causes issue openbmc/openbmc#1420. The fix is to move cpld_trigger before vcs_workaround, which will make CPLD to assert PGOOD before it, and thus before fsi_scan. Then Romulus is able to use the common vcs_workaround service, so p9-vcs-workaround.bbappend is deleted. Fixes openbmc/openbmc#1420 Change-Id: Ia6dee472185c74f382c15acf0e1f2ccb7ad288a2 Signed-off-by: Lei YU <mine260309@gmail.com>
Diffstat (limited to 'meta-openbmc-machines')
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/chassis/cpld-trigger/cpld_trigger@.service2
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/host/op-host-control/vcs_workaround@.service13
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/host/p9-vcs-workaround.bbappend1
3 files changed, 1 insertions, 15 deletions
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/chassis/cpld-trigger/cpld_trigger@.service b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/chassis/cpld-trigger/cpld_trigger@.service
index b1b7e313ab..68c8ed9872 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/chassis/cpld-trigger/cpld_trigger@.service
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/chassis/cpld-trigger/cpld_trigger@.service
@@ -1,7 +1,7 @@
[Unit]
Description=Trigger CPLD to give pgood
Wants=vcs_workaround@%i.service
-After=vcs_workaround@%i.service
+Before=vcs_workaround@%i.service
Wants=obmc-host-start-pre@%i.target
Before=obmc-host-start-pre@%i.target
Conflicts=obmc-power-chassis-off@%i.target
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/host/op-host-control/vcs_workaround@.service b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/host/op-host-control/vcs_workaround@.service
deleted file mode 100644
index fa414b9fba..0000000000
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/host/op-host-control/vcs_workaround@.service
+++ /dev/null
@@ -1,13 +0,0 @@
-[Unit]
-Description=Run VCS workaround on host%i
-Wants=avsbus-enable@%i.service
-After=avsbus-enable@%i.service
-Conflicts=obmc-power-chassis-off@%i.target
-
-[Service]
-ExecStart={sbindir}/openpower-proc-control vcsWorkaround
-Type=oneshot
-RemainAfterExit=yes
-
-[Install]
-WantedBy=obmc-power-chassis-on@%i.target
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/host/p9-vcs-workaround.bbappend b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/host/p9-vcs-workaround.bbappend
deleted file mode 100644
index d1d952ed42..0000000000
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/host/p9-vcs-workaround.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/op-host-control:"