summaryrefslogtreecommitdiff
path: root/meta-openbmc-machines
diff options
context:
space:
mode:
authorEd Tanous <ed.tanous@intel.com>2018-07-17 20:20:09 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-07-19 05:16:51 +0300
commit74a89f930992e7816c7634c23c139a6ad0247f3b (patch)
treea60ca18db4e9968aa7312b8e09a6fdf56f769d65 /meta-openbmc-machines
parent89e86cd92f38f4816b95e3c243be0e44c11cd01f (diff)
downloadopenbmc-74a89f930992e7816c7634c23c139a6ad0247f3b.tar.xz
Fix bmcweb socket activation
It looks like the socket activation part of the recipe got missed in the review. bmcweb can boot without it, but it's still desired to allow people to change what port bmcweb boots on per platform. Tested By: Launching image and verifying bmcweb boots on port 883, and all services are available. Change-Id: Idba19082d80ea4007c6a450219481756bd03938b Signed-off-by: Ed Tanous <ed.tanous@intel.com>
Diffstat (limited to 'meta-openbmc-machines')
-rw-r--r--meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/bmcweb/bmcweb.bb2
-rw-r--r--meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/bmcweb/bmcweb/bmcweb.socket9
2 files changed, 10 insertions, 1 deletions
diff --git a/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/bmcweb/bmcweb.bb b/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/bmcweb/bmcweb.bb
index f74453649f..c2c3b8bd9e 100644
--- a/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/bmcweb/bmcweb.bb
+++ b/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/bmcweb/bmcweb.bb
@@ -24,7 +24,7 @@ inherit cmake
EXTRA_OECMAKE = "-DBMCWEB_BUILD_UT=OFF -DYOCTO_DEPENDENCIES=ON"
-SYSTEMD_SERVICE_${PN} += "bmcweb.service"
+SYSTEMD_SERVICE_${PN} += "bmcweb.service bmcweb.socket"
FULL_OPTIMIZATION = "-Os -pipe "
diff --git a/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/bmcweb/bmcweb/bmcweb.socket b/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/bmcweb/bmcweb/bmcweb.socket
new file mode 100644
index 0000000000..b1db27d475
--- /dev/null
+++ b/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/bmcweb/bmcweb/bmcweb.socket
@@ -0,0 +1,9 @@
+[Unit]
+Description=BMC Webserver socket
+
+[Socket]
+ListenStream=883
+ReusePort=true
+
+[Install]
+WantedBy=sockets.target