summaryrefslogtreecommitdiff
path: root/meta-openbmc-machines
diff options
context:
space:
mode:
authorRatan Gupta <ratagupt@in.ibm.com>2017-04-03 06:16:16 +0300
committerPatrick Williams <patrick@stwcx.xyz>2017-04-08 00:11:46 +0300
commitf7fdd61ea9d5b5a5fe3018a2b830fdea5cde2e38 (patch)
tree1597f8e52dcc854ea0826ea8f252209e3b300ac9 /meta-openbmc-machines
parent9a51f26c625c1c2fbf7798e74d93ec0d7393c18e (diff)
downloadopenbmc-f7fdd61ea9d5b5a5fe3018a2b830fdea5cde2e38.tar.xz
Inventory: Add functional/presence sensor support for garrison
Add the config.yaml which defines the mapping between sensor numbers and Dbus Properties(present,functional) for CPU,Core and DIMM inventory objects. Change-Id: I6ebb4af7d55f012d3615decaefde83702c946a82 Signed-off-by: Ratan Gupta <ratagupt@in.ibm.com>
Diffstat (limited to 'meta-openbmc-machines')
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory%.bbappend1
-rwxr-xr-xmeta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory%/config.yaml987
2 files changed, 988 insertions, 0 deletions
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory%.bbappend b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory%.bbappend
new file mode 100644
index 0000000000..72d991c7e5
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory%.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory%/config.yaml b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory%/config.yaml
new file mode 100755
index 0000000000..20b509ccca
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory%/config.yaml
@@ -0,0 +1,987 @@
+0x21:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm0
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x20:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm1
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x1f:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm2
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x1e:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm3
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x25:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm4
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x24:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm5
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x23:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm6
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x22:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm7
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x29:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm8
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x28:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm9
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x27:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm10
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x26:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm11
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x2d:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm12
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x2c:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm13
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x2b:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm14
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x2a:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm15
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x31:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm16
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x30:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm17
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x2f:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm18
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x2e:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm19
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x35:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm20
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x34:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm21
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x33:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm22
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x32:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm23
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x39:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm24
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x38:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm25
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x37:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm26
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x36:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm27
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x3d:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm28
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x3c:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm29
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x3b:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm30
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x3a:
+ sensorType: 0x0C
+ path: /system/chassis/motherboard/dimm31
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x06:
+ type: bool
+ assert: true
+ deassert: false
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x04:
+ assert: false
+ deassert: true
+ type: bool
+0x0c:
+ sensorType: 0x07
+ path: /system/chassis/motherboard/cpu0
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x08:
+ deassert: true
+ assert: false
+ type: bool
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x07:
+ deassert: false
+ assert: true
+ type: bool
+0x0e:
+ sensorType: 0x07
+ path: /system/chassis/motherboard/cpu1
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x08:
+ deassert: true
+ assert: false
+ type: bool
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x07:
+ deassert: false
+ assert: true
+ type: bool
+
+0x3e:
+ sensorType: 0x07
+ path: /system/chassis/motherboard/cpu0/core0
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x08:
+ deassert: true
+ assert: false
+ type: bool
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x07:
+ deassert: false
+ assert: true
+ type: bool
+0x3f:
+ sensorType: 0x07
+ path: /system/chassis/motherboard/cpu0/core1
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x08:
+ deassert: true
+ assert: false
+ type: bool
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x07:
+ deassert: false
+ assert: true
+ type: bool
+0x40:
+ sensorType: 0x07
+ path: /system/chassis/motherboard/cpu0/core2
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x08:
+ deassert: true
+ assert: false
+ type: bool
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x07:
+ deassert: false
+ assert: true
+ type: bool
+0x41:
+ sensorType: 0x07
+ path: /system/chassis/motherboard/cpu0/core3
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x08:
+ deassert: true
+ assert: false
+ type: bool
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x07:
+ deassert: false
+ assert: true
+ type: bool
+0x42:
+ sensorType: 0x07
+ path: /system/chassis/motherboard/cpu0/core4
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x08:
+ deassert: true
+ assert: false
+ type: bool
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x07:
+ deassert: false
+ assert: true
+ type: bool
+0x43:
+ sensorType: 0x07
+ path: /system/chassis/motherboard/cpu0/core5
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x08:
+ deassert: true
+ assert: false
+ type: bool
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x07:
+ deassert: false
+ assert: true
+ type: bool
+0x44:
+ sensorType: 0x07
+ path: /system/chassis/motherboard/cpu0/core6
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x08:
+ deassert: true
+ assert: false
+ type: bool
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x07:
+ deassert: false
+ assert: true
+ type: bool
+0x45:
+ sensorType: 0x07
+ path: /system/chassis/motherboard/cpu0/core7
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x08:
+ deassert: true
+ assert: false
+ type: bool
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x07:
+ deassert: false
+ assert: true
+ type: bool
+0x46:
+ sensorType: 0x07
+ path: /system/chassis/motherboard/cpu0/core8
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x08:
+ deassert: true
+ assert: false
+ type: bool
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x07:
+ deassert: false
+ assert: true
+ type: bool
+0x47:
+ sensorType: 0x07
+ path: /system/chassis/motherboard/cpu0/core9
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x08:
+ deassert: true
+ assert: false
+ type: bool
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x07:
+ deassert: false
+ assert: true
+ type: bool
+0x48:
+ sensorType: 0x07
+ path: /system/chassis/motherboard/cpu0/core10
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x08:
+ deassert: true
+ assert: false
+ type: bool
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x07:
+ deassert: false
+ assert: true
+ type: bool
+0x49:
+ sensorType: 0x07
+ path: /system/chassis/motherboard/cpu0/core11
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x08:
+ deassert: true
+ assert: false
+ type: bool
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x07:
+ deassert: false
+ assert: true
+ type: bool
+0x4a:
+ sensorType: 0x07
+ path: /system/chassis/motherboard/cpu1/core0
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x08:
+ deassert: true
+ assert: false
+ type: bool
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x07:
+ deassert: false
+ assert: true
+ type: bool
+0x4b:
+ sensorType: 0x07
+ path: /system/chassis/motherboard/cpu1/core1
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x08:
+ deassert: true
+ assert: false
+ type: bool
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x07:
+ deassert: false
+ assert: true
+ type: bool
+0x4c:
+ sensorType: 0x07
+ path: /system/chassis/motherboard/cpu1/core2
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x08:
+ deassert: true
+ assert: false
+ type: bool
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x07:
+ deassert: false
+ assert: true
+ type: bool
+0x4d:
+ sensorType: 0x07
+ path: /system/chassis/motherboard/cpu1/core3
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x08:
+ deassert: true
+ assert: false
+ type: bool
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x07:
+ deassert: false
+ assert: true
+ type: bool
+0x4e:
+ sensorType: 0x07
+ path: /system/chassis/motherboard/cpu1/core4
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x08:
+ deassert: true
+ assert: false
+ type: bool
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x07:
+ deassert: false
+ assert: true
+ type: bool
+0x4f:
+ sensorType: 0x07
+ path: /system/chassis/motherboard/cpu1/core5
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x08:
+ deassert: true
+ assert: false
+ type: bool
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x07:
+ deassert: false
+ assert: true
+ type: bool
+0x50:
+ sensorType: 0x07
+ path: /system/chassis/motherboard/cpu1/core6
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x08:
+ deassert: true
+ assert: false
+ type: bool
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x07:
+ deassert: false
+ assert: true
+ type: bool
+0x51:
+ sensorType: 0x07
+ path: /system/chassis/motherboard/cpu1/core7
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x08:
+ deassert: true
+ assert: false
+ type: bool
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x07:
+ deassert: false
+ assert: true
+ type: bool
+0x52:
+ sensorType: 0x07
+ path: /system/chassis/motherboard/cpu1/core8
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x08:
+ deassert: true
+ assert: false
+ type: bool
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x07:
+ deassert: false
+ assert: true
+ type: bool
+0x53:
+ sensorType: 0x07
+ path: /system/chassis/motherboard/cpu1/core9
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x08:
+ deassert: true
+ assert: false
+ type: bool
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x07:
+ deassert: false
+ assert: true
+ type: bool
+0x54:
+ sensorType: 0x07
+ path: /system/chassis/motherboard/cpu1/core10
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x08:
+ deassert: true
+ assert: false
+ type: bool
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x07:
+ deassert: false
+ assert: true
+ type: bool
+0x55:
+ sensorType: 0x07
+ path: /system/chassis/motherboard/cpu1/core11
+ sensorReadingType: 0x6F
+ interfaces:
+ xyz.openbmc_project.State.Decorator.OperationalStatus:
+ Functional:
+ 0x08:
+ deassert: true
+ assert: false
+ type: bool
+ xyz.openbmc_project.Inventory.Item:
+ Present:
+ 0x07:
+ deassert: false
+ assert: true
+ type: bool