summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-networking/recipes-connectivity/samba
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2019-02-23 01:03:50 +0300
committerAndrew Geissler <geissonator@yahoo.com>2019-02-23 01:05:07 +0300
commit1548c07ccf17a3a7a4fad7f31fb62d117bcb674f (patch)
treedc38b5d3eba36dab80ecd70556e05f4fae917c12 /meta-openembedded/meta-networking/recipes-connectivity/samba
parent8704effb21a9aac3e4c97d234149887b6acfa941 (diff)
downloadopenbmc-1548c07ccf17a3a7a4fad7f31fb62d117bcb674f.tar.xz
meta-openembedded: refresh thud: cca27b5ea7..6ef9657068
Update meta-openembedded to thud HEAD. Alexander Kanavin (2): packagegroup-meta-oe: drop ptest packages that do not exist packagegroup-meta-oe: rename the group that contains ptest packages Andrea Adami (4): klibc: fix build for mipsel and mips64el with security flags enabled waf-cross-answers: Add cross-answers-mips64el.txt kexec-tools-klibc: fix build for mipsel and mips64el samba: fix build on qemumips64 with musl Andreas Müller (1): libgit2: Fix install for multilib Armin Kuster (1): wireshark: update to 2.6.6 Craig McQueen (1): python3-multidict: Workaround for broken make clean Eduardas Meile (1): toybox: fix to use "usrmerge" distro feature properly Haiqing Bai (1): ptpd: fixed the issue of ptpd2 daemon takes 100% CPU Hong Liu (1): wireshark: upgrade to 2.6.5 Hongxu Jia (1): python-pyparted/python3-pyparted: drop incorrect and redundant PV Kai Kang (1): net-snmp: inherit ptest Khem Raj (16): xscreensaver: Define consistent app-defaults dir a2jmidid: Define own do_configure bpftool: don't build under musl packagegroup-meta-oe: Remove arch specific packages as needed packagegroup-meta-oe: Remove packages which don't build for musl modemmanager: Fix build with clang klibc: Fix build with clang srecord: GPL-3.0 and LGPL-3.0 is correct license packagegroup-meta-oe: Exclude unbuildable packages on mips64 packagegroup-meta-oe: Exclude android-tools breakpad on ppc packagegroup-meta-oe: Remove unbuildable packages on risc-v from rdep mpv: Disable lua on mips/aarch64 luajit: Disable for mips n64/n32 hosts licenses: Add Arphic-Public-License text nmap: Fix build with clang8/musl/libc++ mozjs: Fix symbol visibility with clang/libc++ Marc Ferland (1): networkmanager: fix QA issue when using modemmanager and ppp in PACKAGECONFIG Martin Jansa (1): open-vm-tools: fix indentation and drop FILES_${PN}-dbg Mingli Yu (1): vim: improve reproducibility Niko Mauno (7): python-pygobject: Fix invalid install path python-pygobject: Drop redundant PYTHON* refs python-pygobject: Drop redundant dependencies python-pygobject: Only check for even upstream versions python-pygobject: Remove duplication in inherit python-pygobject: Fix style issue python-pygobject: Tune remove operation Otavio Salvador (2): mozjs: Avoid use of X11 from host when X11 is disabled postgresql: Allow successful run of postgresql-setup Primoz Fiser (1): sedutil: fix compile errors on big endian architectures Scott Ellis (2): nmap: Fix typo in pcre PACKAGECONFIG nmap: Include additional FILES path for certs leimaohui (2): mraa: To file do_package error in multilib. makedumpfile: Add aarch64 into COMPATIBLE_HOST. thc (1): fix networkmanager apppend Change-Id: I979f5ccefeec364f27df10888ae6258923a30659 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-openembedded/meta-networking/recipes-connectivity/samba')
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/samba/samba/cmocka-uintptr_t.patch51
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/samba/samba_4.8.4.bb1
2 files changed, 52 insertions, 0 deletions
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/samba/samba/cmocka-uintptr_t.patch b/meta-openembedded/meta-networking/recipes-connectivity/samba/samba/cmocka-uintptr_t.patch
new file mode 100644
index 0000000000..5c299d617b
--- /dev/null
+++ b/meta-openembedded/meta-networking/recipes-connectivity/samba/samba/cmocka-uintptr_t.patch
@@ -0,0 +1,51 @@
+From 5bd7b5d04435bd593349825973ce32290f5f604d Mon Sep 17 00:00:00 2001
+From: Changqing Li <changqing.li@windriver.com>
+Date: Wed, 25 Jul 2018 09:55:25 +0800
+Subject: [PATCH] samba: cmocka.h: fix musl libc conflicting types error
+
+Fix build on qemumips64(el)
+
+taken from:
+[PATCH] libldb: fix musl libc conflicting types error
+
+/third_party/cmocka/cmocka.h:126:28: error: conflicting types for 'uintptr_t'
+ typedef unsigned int uintptr_t;
+ ^~~~~~~~~
+use __DEFINED_uintptr_t in alltypes.h to check if uintptr already defined
+
+Upstream-Status: Pending
+
+Signed-off-by: Changqing Li <changqing.li@windriver.com>
+Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
+---
+ third_party/cmocka/cmocka.h | 7 +++----
+ 1 file changed, 3 insertions(+), 4 deletions(-)
+
+diff --git a/third_party/cmocka/cmocka.h b/third_party/cmocka/cmocka.h
+index 4fd82a9..5443a08 100644
+--- a/third_party/cmocka/cmocka.h
++++ b/third_party/cmocka/cmocka.h
+@@ -110,7 +110,7 @@ typedef uintmax_t LargestIntegralType;
+ ((LargestIntegralType)(value))
+
+ /* Smallest integral type capable of holding a pointer. */
+-#if !defined(_UINTPTR_T) && !defined(_UINTPTR_T_DEFINED)
++#if !defined(__DEFINED_uintptr_t)
+ # if defined(_WIN32)
+ /* WIN32 is an ILP32 platform */
+ typedef unsigned int uintptr_t;
+@@ -134,9 +134,8 @@ typedef uintmax_t LargestIntegralType;
+ # endif /* __WORDSIZE */
+ # endif /* _WIN32 */
+
+-# define _UINTPTR_T
+-# define _UINTPTR_T_DEFINED
+-#endif /* !defined(_UINTPTR_T) || !defined(_UINTPTR_T_DEFINED) */
++# define __DEFINED_uintptr_t
++#endif /* !defined(__DEFINED_uintptr_t) */
+
+ /* Perform an unsigned cast to uintptr_t. */
+ #define cast_to_pointer_integral_type(value) \
+--
+2.7.4
+
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/samba/samba_4.8.4.bb b/meta-openembedded/meta-networking/recipes-connectivity/samba/samba_4.8.4.bb
index da0ac322a7..f1aaeb83d9 100644
--- a/meta-openembedded/meta-networking/recipes-connectivity/samba/samba_4.8.4.bb
+++ b/meta-openembedded/meta-networking/recipes-connectivity/samba/samba_4.8.4.bb
@@ -28,6 +28,7 @@ SRC_URI = "${SAMBA_MIRROR}/stable/samba-${PV}.tar.gz \
SRC_URI_append_libc-musl = " \
file://samba-pam.patch \
file://samba-4.3.9-remove-getpwent_r.patch \
+ file://cmocka-uintptr_t.patch \
"
SRC_URI[md5sum] = "ca5bfbebd8d9eb95506e16594b2bbee2"