summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-crypto
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-11-25 17:40:59 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-11-25 17:41:09 +0300
commit8410d61f39efb52ffab1dc89efb05ca3ae837907 (patch)
tree3fd23d8e51ed9b3e9c4aa01514aaf778674cad14 /meta-openembedded/meta-oe/recipes-crypto
parent1065cc2853e5509b7e5dd07a87fec8dc22b7c970 (diff)
downloadopenbmc-8410d61f39efb52ffab1dc89efb05ca3ae837907.tar.xz
meta-openembedded: subtree update:53d431639a..e4ac09169d
Andreas Müller (9): file-roller: add gsettings to inherit tracker: add gsettings to inherit nautilus: add gsettings to inherit libgweather: add gsetings & upstream-version-is-even to inherit gnome-settings-daemon: add gsettings to inherit gnome-terminal: add gsettings to inherit parole: upgrade 1.0.4 -> 1.0.5 exo: upgrade 0.12.8 -> 0.12.9 gedit: add gsettings to inherit Changqing Li (1): dnsmasq.conf: fix dnsmasq path Denys Dmytriyenko (1): recipes: rename distro_features_check to features_check Jan Luebbe (6): openct: merge do_install and do_install_append pcsc-lite: add support for native builds opensc: use pcsc-lite instead of openct by default opensc: add support for native builds libp11: add support for native builds softhsm: add recipe Kai Kang (1): mariadb: replace dependency readline with libedit Khem Raj (6): dlm: Drop -fstack-clash-protection for clang ruli: Fix install step and build samples too libkcapi: Update patch to upstream submitted one sanlock: Use python3 and add sanlock user/group sanlock: Replace cp -a with cp -R --no-dereference nodejs: libatomic patch should be target specific Lei YU (1): googletest: move to release 1.10.0 Nicola Lunghi (4): python3-importlib-metadata: fix class-target overriding default dependencies python-configparser: Add native and nativesdk to BBCLASSEXTEND python-contextlib2: Add native and nativesdk to BBCLASSEXTEND python-scandir: Add native and nativesdk to BBCLASSEXTEND Paul Barker (1): liblockfile: Rename patch Qi.Chen@windriver.com (1): python-jsonschema: add missing dependency Ross Burton (1): python-babel: add BBCLASSEXTEND for native/nativesdk Rouven Czerwinski (1): python-pyelftools: add recipes Stefan Agner (2): haveged: use the Fedora service file available from upstream networkmanager: do not deploy unnecessary udev rule file Wang Mingyu (3): mcelog: upgrade 1.65 -> 1.66 hwdata: upgrade 0.328 -> 0.329 libdev-checklib-perl: upgrade 1.13 -> 1.14 Zang Ruochen (17): python-zopeinterface: upgrade 4.6.0 -> 4.7.1 python-yappi: upgrade 0.98 -> 1.0 python-xstatic: upgrade 1.0.1 -> 1.0.2 python-xlrd: upgrade 1.1.0 -> 1.2.0 python-urllib3: upgrade 1.25.6 -> 1.25.7 python-tzlocal: upgrade 1.5.1 -> 2.0.0 python-twitter: upgrade 3.7.0 -> 3.8.0 python-twisted: upgrade 19.7.0 -> 19.10.0 python3-meh: upgrade 0.47 -> 0.48 python-pyephem: upgrade 3.7.6.0 -> 3.7.7.0 python3-pykickstart: upgrade 3.20 -> 3.22 python-pyparted: upgrade 3.11.2 -> 3.11.3 libextutils-cppguess-perl: upgrade 0.12 -> 0.20 libmoo-perl: upgrade 2.003004 -> 2.003006 libdbd-sqlite-perl: upgrade 1.62 -> 1.64 libclass-method-modifiers-perl: upgrade 2.12 -> 2.13 librole-tiny-perl: upgrade 2.000006 -> 2.001004 niko.mauno@vaisala.com (2): gitpkgv.bbclass: Use --git-dir option gitpkgv.bbclass: Support also lightweight tags Change-Id: I00fb24df7bb3849ed0c9337a66623d9b4cba5999 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-crypto')
-rw-r--r--meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-Use-__builtin_bswap32-on-Clang-if-supported.patch39
-rw-r--r--meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-kcapi-kdf-Move-code-to-fix.patch24
-rw-r--r--meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi_git.bb1
3 files changed, 53 insertions, 11 deletions
diff --git a/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-Use-__builtin_bswap32-on-Clang-if-supported.patch b/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-Use-__builtin_bswap32-on-Clang-if-supported.patch
new file mode 100644
index 0000000000..e713665ab3
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-Use-__builtin_bswap32-on-Clang-if-supported.patch
@@ -0,0 +1,39 @@
+From 7b5dd67fee58f9f54c8a676abe2131776c0a3c52 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 20 Nov 2019 13:41:39 -0800
+Subject: [PATCH] Use __builtin_bswap32 on Clang if supported
+
+clang pretends to be gcc 4.2.1 so GCC_VERSION macro will decide that
+__builtin_bswap32 is not supported on clang, whereas in reality it might
+so its better to add a check for enquiring clang if it supports
+__builtin_bswap32 or not
+
+Upstream-Status: Submitted [https://github.com/smuellerDD/libkcapi/pull/83]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ lib/kcapi-kdf.c | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/lib/kcapi-kdf.c b/lib/kcapi-kdf.c
+index 9e53a0b..f32fbe9 100644
+--- a/lib/kcapi-kdf.c
++++ b/lib/kcapi-kdf.c
+@@ -54,10 +54,14 @@
+ #include "kcapi.h"
+ #include "internal.h"
+
++#ifndef __has_builtin
++# define __has_builtin(x) 0
++#endif
++
+ #define GCC_VERSION (__GNUC__ * 10000 \
+ + __GNUC_MINOR__ * 100 \
+ + __GNUC_PATCHLEVEL__)
+-#if GCC_VERSION >= 40400
++#if GCC_VERSION >= 40400 || (defined(__clang__) && __has_builtin(__builtin_bswap32))
+ # define __HAVE_BUILTIN_BSWAP32__
+ #endif
+
+--
+2.24.0
+
diff --git a/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-kcapi-kdf-Move-code-to-fix.patch b/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-kcapi-kdf-Move-code-to-fix.patch
index 3dd7ea7f9b..7ed9caf096 100644
--- a/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-kcapi-kdf-Move-code-to-fix.patch
+++ b/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-kcapi-kdf-Move-code-to-fix.patch
@@ -1,4 +1,4 @@
-From 00c1654e368f728b213c4e3782045d54098edb25 Mon Sep 17 00:00:00 2001
+From 8f961521add49278b48c9721fc53e05ee3543b74 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Sat, 16 Nov 2019 23:03:51 -0800
Subject: [PATCH] kcapi-kdf: Move code to fix
@@ -6,13 +6,14 @@ Subject: [PATCH] kcapi-kdf: Move code to fix
Fixes clang build
unused function '_bswap32' [-Werror,-Wunused-function]
+Upstream-Status: Submitted [https://github.com/smuellerDD/libkcapi/pull/83]
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
- lib/kcapi-kdf.c | 36 ++++++++++++++++--------------------
- 1 file changed, 16 insertions(+), 20 deletions(-)
+ lib/kcapi-kdf.c | 37 +++++++++++++++++--------------------
+ 1 file changed, 17 insertions(+), 20 deletions(-)
diff --git a/lib/kcapi-kdf.c b/lib/kcapi-kdf.c
-index ea39846..8e4a636 100644
+index ea39846..9e53a0b 100644
--- a/lib/kcapi-kdf.c
+++ b/lib/kcapi-kdf.c
@@ -54,6 +54,20 @@
@@ -26,17 +27,17 @@ index ea39846..8e4a636 100644
+# define __HAVE_BUILTIN_BSWAP32__
+#endif
+
-+#ifdef __HAVE_BUILTIN_BSWAP32__
-+# define be_bswap32(x) (uint32_t)__builtin_bswap32((uint32_t)(x))
+/* Endian dependent byte swap operations. */
-+#elif __BYTE_ORDER__ == __ORDER_BIG_ENDIAN__
++#if __BYTE_ORDER__ == __ORDER_BIG_ENDIAN__
+# define be_bswap32(x) ((uint32_t)(x))
+#elif __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__
-+
++# ifdef __HAVE_BUILTIN_BSWAP32__
++# define be_bswap32(x) (uint32_t)__builtin_bswap32((uint32_t)(x))
++# else
static inline uint32_t rol32(uint32_t x, int n)
{
return ( (x << (n&(32-1))) | (x >> ((32-n)&(32-1))) );
-@@ -68,27 +82,9 @@ static inline uint32_t _bswap32(uint32_t x)
+@@ -68,27 +82,10 @@ static inline uint32_t _bswap32(uint32_t x)
{
return ((rol32(x, 8) & 0x00ff00ffL) | (ror32(x, 8) & 0xff00ff00L));
}
@@ -59,10 +60,11 @@ index ea39846..8e4a636 100644
-# define be_bswap32(x) ((uint32_t)(x))
-#elif __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__
-# define be_bswap32(x) _swap32(x)
-+# define be_bswap32(x) _bswap32(x)
++# define be_bswap32(x) _bswap32(x)
++# endif
#else
-#error "Endianess not defined"
-+# error "Neither builtin_bswap32 nor endianess defined"
++# error "endianess not defined"
#endif
DSO_PUBLIC
diff --git a/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi_git.bb b/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi_git.bb
index aa438e5859..4e217a351d 100644
--- a/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi_git.bb
+++ b/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi_git.bb
@@ -11,6 +11,7 @@ PV = "1.1.5"
SRC_URI = " \
git://github.com/smuellerDD/libkcapi.git \
file://0001-kcapi-kdf-Move-code-to-fix.patch \
+ file://0001-Use-__builtin_bswap32-on-Clang-if-supported.patch \
"
inherit autotools