summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-extended/redis
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-13 13:17:45 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-13 13:17:50 +0300
commita891d150c6a7455ddbb797bdc472f45fd5f36008 (patch)
tree675a1c6f76065884b0c99b5a6056c79de44ef083 /meta-openembedded/meta-oe/recipes-extended/redis
parent4bfffde7b5edeee761d32b174386bd1e1e28fab9 (diff)
downloadopenbmc-a891d150c6a7455ddbb797bdc472f45fd5f36008.tar.xz
meta-openembedded: subtree update:ce51958eca..a2928764c2
Adrian Bunk (3): python3-cmd2: Remove PNBLACKLIST php: Remove no longer needed CFLAGS_append_aarch64 php: Move more into php.inc after php5 removal Alistair Francis (4): python3-requests-future: Initial commit of 0.9.5 python3-xmlrunner: Initial commit of 1.7.7 python3-fasteners: Initial commit of 0.15 python3-python-vlc: Initial commit of 3.0.7110 Anuj Mittal (3): python3-defusedxml: add recipe python-networkx: upgrade 2.1 -> 2.2 python3-networkx: add recipe Khem Raj (9): php: Turn PCRE JIT off for riscv redis: Fix build with clang/x86 android-tools: Recognise i686 for HOST_ARCH netdata: Update to 1.17.0 and fix build with clang/x86 safec: Define _GNU_SOURCE safec: Upgrade to 3.5 release openocd: Add --disable-werror always breakpad: Update dont-clobber-rsp patch to latest gparted: add to deps instead of overwriting Martin Jansa (3): remmina: add distro_features_check for GTK3DISTROFEATURES ceres-solver: fix the paths in .cmake files ceres-solver: add PACKAGECONFIG for suitesparse and lapack Naveen Saini (1): pm-graph: upgrade 5.3 -> 5.5 Oleksandr Kravchuk (1): analyze-suspend: update to 5.5 Peter Kjellerstedt (1): lvm2/libdevmapper: Make it build for native Randy MacLeod (1): poppler: update from 0.79.0 to 0.80.0 Slater, Joseph (1): openhpi: control snmp-bc ptest generation Stefan Agner (1): fuse3: add libfuse3 recipe Trevor Gamblin (1): gvfs: upgrade 1.40.2 -> 1.41.2 for CVE fixes Yi Zhao (2): php: fix module path in mod_php.conf apache-websocket: fix module path Yuan Chao (2): python-atomicwrites: new recipe python-pytest: fix runtime error Zang Ruochen (1): python-certifi: upgrade 2019.6.16 -> 2019.9.11 Change-Id: Iba065b25686a1ac22d647226d9ea0c61c5b4578f Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-extended/redis')
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/redis/redis/0001-src-Do-not-reset-FINAL_LIBS.patch32
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/redis/redis_4.0.14.bb5
2 files changed, 36 insertions, 1 deletions
diff --git a/meta-openembedded/meta-oe/recipes-extended/redis/redis/0001-src-Do-not-reset-FINAL_LIBS.patch b/meta-openembedded/meta-oe/recipes-extended/redis/redis/0001-src-Do-not-reset-FINAL_LIBS.patch
new file mode 100644
index 0000000000..04af15dd86
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-extended/redis/redis/0001-src-Do-not-reset-FINAL_LIBS.patch
@@ -0,0 +1,32 @@
+From 97584e1eb78dc18599534b47b6670c20c63f5ee2 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 10 Sep 2019 20:04:26 -0700
+Subject: [PATCH] src: Do not reset FINAL_LIBS
+
+This helps case where additional libraries are needed to be passed from
+environment to get it going
+
+e.g. -latomic is needed on clang/x86 to provide for 64bit atomics
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Makefile b/src/Makefile
+index 7f7c625..c71dd3b 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -66,7 +66,7 @@ endif
+
+ FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) $(REDIS_CFLAGS)
+ FINAL_LDFLAGS=$(LDFLAGS) $(REDIS_LDFLAGS) $(DEBUG)
+-FINAL_LIBS=-lm
++FINAL_LIBS+=-lm
+ DEBUG=-g -ggdb
+
+ ifeq ($(uname_S),SunOS)
+--
+2.23.0
+
diff --git a/meta-openembedded/meta-oe/recipes-extended/redis/redis_4.0.14.bb b/meta-openembedded/meta-oe/recipes-extended/redis/redis_4.0.14.bb
index 5df5312a0f..45ea29b702 100644
--- a/meta-openembedded/meta-oe/recipes-extended/redis/redis_4.0.14.bb
+++ b/meta-openembedded/meta-oe/recipes-extended/redis/redis_4.0.14.bb
@@ -11,6 +11,7 @@ SRC_URI = "http://download.redis.io/releases/${BP}.tar.gz \
file://lua-update-Makefile-to-use-environment-build-setting.patch \
file://oe-use-libc-malloc.patch \
file://Fixed-stack-trace-generation-on-aarch64.patch \
+ file://0001-src-Do-not-reset-FINAL_LIBS.patch \
file://redis.conf \
file://init-redis-server \
file://redis.service \
@@ -25,11 +26,13 @@ SRC_URI[sha256sum] = "1e1e18420a86cfb285933123b04a82e1ebda20bfb0a289472745a08758
inherit autotools-brokensep update-rc.d systemd useradd
+FINAL_LIBS_x86_toolchain-clang = "-latomic"
+export FINAL_LIBS
+
USERADD_PACKAGES = "${PN}"
USERADD_PARAM_${PN} = "--system --home-dir /var/lib/redis -g redis --shell /bin/false redis"
GROUPADD_PARAM_${PN} = "--system redis"
-
REDIS_ON_SYSTEMD = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}"
do_compile_prepend() {