summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-extended/sedutil/files/0001-include-missing-cstdint.patch
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2023-01-30 22:28:01 +0300
committerPatrick Williams <patrick@stwcx.xyz>2023-01-30 23:15:34 +0300
commitb9af8750acfaddd4a8b99c3e289510b5476c90f3 (patch)
tree53385dd5fc99ccf4869c9c80fcd1e98e100fe81f /meta-openembedded/meta-oe/recipes-extended/sedutil/files/0001-include-missing-cstdint.patch
parent70d69cd8440d2a940a971f262a3e36cc78781461 (diff)
downloadopenbmc-b9af8750acfaddd4a8b99c3e289510b5476c90f3.tar.xz
subtree updates
meta-security: 3d9dab6d14..7eed4a60f5: Armin Kuster (2): linux-yocto.bbappend: bump to kernel version 6.x meta-tpm: bump linux-yocto to 6.x kernel Max Krummenacher (1): samhain: rework due to changed cache handling meta-openembedded: 2ab113e8be..ea63f13846: Beniamin Sandu (1): mbedtls: export source files/headers needed by ATF Khem Raj (13): poco: Do not use std::atomic<bool> libwebsockets: Fix build with gcc13 v4l-utils: Fix build with gcc13 proj: Upgrade to 9.1.1 release mpd: Upgrade to 0.23.12 release geos: Upgrade to 3.9.4 geos: Fix build with gcc13 libinih: Upgrade to version 56 python3-pybind11: Upgrade to 2.10.3 waylandpp: Fix build with gcc-13 sedutil: Fix build with gcc13 usbguard: Fix build with gcc13 minifi-cpp: Fix build with gcc13 Martin Jansa (6): keyutils: fix Upstream-Status formatting gphoto2: fix Upstream-Status formatting .patch: fix Upstream-Status formatting issues reported by patchreview tool from oe-core android-tools: fix Upstream-Status formatting mm-common: fix Upstream-Status formatting .patch: fix Signed-off-by formatting issues reported by patchreview tool from oe-core poky: 5e249ec855..29afbb5e14: Alejandro Hernandez Samaniego (1): newlib: Upgrade 4.2.0 -> 4.3.0 Alexander Kanavin (1): gdk-pixbuf: do not use tools from gdk-pixbuf-native when building tests Armin Kuster (1): lttng-modules: Fix for 5.10.163 kernel version Khem Raj (3): valgrind: Include missing <cstdint> webkitgtk: Fix build with gcc 13 gdb: Define alignof using _Alignof when using C11 or newer Richard Purdie (3): make-mod-scripts: Ensure kernel build output is deterministic bitbake.conf: Inject a dash into PN for BB_HASH_CODEPARSER_VALS scripts/bitbake-prserv-tool: Fix to work with memres bitbake Ross Burton (1): Revert "cve-update-db-native: show IP on failure" meta-arm: 3d51e1117d..aecbb77f72: Jon Mason (4): arm/qemuarm-secureboot: Changes for v2023.01 u-boot arm-bsp/juno: update to use u-boot v2023.01 arm-bsp/juno: update kernel patches for 6.1 arm-bsp/fvp-base: update kernel config to remove warning Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: Ia335876b7ce9a4c9d19ca41ae321b266b3b6d00e
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-extended/sedutil/files/0001-include-missing-cstdint.patch')
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/sedutil/files/0001-include-missing-cstdint.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-extended/sedutil/files/0001-include-missing-cstdint.patch b/meta-openembedded/meta-oe/recipes-extended/sedutil/files/0001-include-missing-cstdint.patch
new file mode 100644
index 0000000000..8afcb1fa48
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-extended/sedutil/files/0001-include-missing-cstdint.patch
@@ -0,0 +1,32 @@
+From 927cd88cad7bea94c2eebecc18f7881f0defaccb Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 26 Jan 2023 23:36:29 -0800
+Subject: [PATCH] include missing <cstdint>
+
+gcc 13 moved some includes around and as a result <cstdint>
+is no longer transitively included [1]. Explicitly include
+it for uint{32,64}_t.
+
+[1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
+
+Upstream-Status: Submitted [https://github.com/Drive-Trust-Alliance/sedutil/pull/425]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ Common/DtaOptions.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Common/DtaOptions.h b/Common/DtaOptions.h
+index c012af1..7530a0b 100644
+--- a/Common/DtaOptions.h
++++ b/Common/DtaOptions.h
+@@ -21,6 +21,7 @@ along with sedutil. If not, see <http://www.gnu.org/licenses/>.
+ #ifndef _DTAOPTIONS_H
+ #define _DTAOPTIONS_H
+
++#include <cstdint>
+ /** Output modes */
+ typedef enum _sedutiloutput {
+ sedutilNormal,
+--
+2.39.1
+