summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/mcelog/mcelog_170.bb
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-06-06 01:59:17 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-06-06 02:11:09 +0300
commiteafcbb8a73edfad32d50070982300335b553e28e (patch)
treea5f04eb03300cc0b1a959c024e40720f6e8252bd /meta-openembedded/meta-oe/recipes-support/mcelog/mcelog_170.bb
parentccb96fccef02f3812b232a8a1d105925d1ea2458 (diff)
downloadopenbmc-eafcbb8a73edfad32d50070982300335b553e28e.tar.xz
meta-openembedded: subtree update:713e70bd25..5caca0f7bd
Andreas Müller (1): fluidsynth: upgrade 2.1.2 -> 2.1.3 Domarys Correa (6): python3-pytest: Update 5.3.5 -> 5.4.2 python3-pytest-html: Update 1.6 -> 2.1.1 python3-pytest-metadata: Update 1.8.0 -> 1.9.0 python3-pytest-asyncio: Update 0.10.0 -> 0.12.0 python3-pyudev: Update 0.21.0 -> 0.22.0 python3-pyyaml: Update 5.3 -> 5.3.1 Hongxu Jia (1): multipath-tools: fix compiling parallel issue Kai Kang (1): plymouth: disable systemd-integration for sysvinit Khem Raj (1): dfu-util-native: Remove DEPLOY_DIR_TOOLS from sstate-outputdirs Konrad Weihmann (14): pugixml: fix typo for homepage distuils-extra: fix typo for DESCRIPTION brotli: fix typo for DESCRIPTION wxwidgets: fix typo for DESCRIPTION passwdqc: remove double modify operation zbar: fix typo for DESCRIPTION sound-theme-freedesktop: remove double depends python3-cmd2: remove double colorama in RDEPENDS python3-smbus2: remove duplicate RDEPENDS settings python3-twisted: remove double var modification spawn-fcgi: fix typo in SUMMARY physfs: fix typo for HOMEPAGE rest: fix typo for HOMEPAGE proftpd: Fix typo for SRC_URI[md5sum] Leon Anavi (4): python3-click: Upgrade 7.0 -> 7.1.2 python3-dbussy: Upgrade 1.2.1 -> 1.3 python3-imageio: Upgrade 2.6.0 -> 2.8.0 python3-colorama: Upgrade 0.4.1 -> 0.4.3 Maciej Pijanowski (1): qpdf: fix typo in RDEPENDS Martin Jansa (1): irssi: package libirc_proxy.a in PN-staticdev Michael Haener (1): cockpit: 219 -> 220 Patrick Williams (1): net-snmp: refresh patches Pierre-Jean Texier (2): libuv: upgrade 1.36.0 -> 1.38.0 uftp: upgrade 4.10.2 -> 5.0 Robert P. J. Day (1): use weak assignments for PNBLACKLIST in recipe files Shlomi Vaknin (1): add python bitstring package Zang Ruochen (6): libgphoto2: upgrade 2.5.24 -> 2.5.25 rsyslog: upgrade 8.2002 -> 8.2004 mosquitto: upgrade 1.6.9 -> 1.6.10 snort: upgrade 2.9.15 -> 2.9.16 wireshark: upgrade 3.2.2 -> 3.2.4 cpuid: upgrade 20200211 -> 20200427 Zheng Ruoqin (5): nano: upgrade 4.9.2 -> 4.9.3 gsoap: upgrade 2.8.100 -> 2.8.103 logwatch: upgrade 7.5.1 -> 7.5.3 mcelog: upgrade 168 -> 170 libnet-dns-perl: upgrade 1.23 -> 1.24 Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I697f91df13d9e8d8cb15620aeccd644cdfe53a43
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/mcelog/mcelog_170.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/mcelog/mcelog_170.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/mcelog/mcelog_170.bb b/meta-openembedded/meta-oe/recipes-support/mcelog/mcelog_170.bb
new file mode 100644
index 0000000000..bdb080f418
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/mcelog/mcelog_170.bb
@@ -0,0 +1,35 @@
+SUMMARY = "mcelog daemon accounts memory and some other errors in various ways."
+DESCRIPTION = "mcelog is required by both 32bit x86 Linux kernels (since 2.6.30) \
+and 64bit Linux kernels (since early 2.6 kernel releases) to log machine checks \
+and should run on all Linux systems that need error handling."
+HOMEPAGE = "http://mcelog.org/"
+SECTION = "System Environment/Base"
+
+SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git;protocol=http; \
+ file://run-ptest \
+"
+
+SRCREV = "391abaac9bdff385934b18134789bcc98b0adeb7"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://README.md;md5=74bb47b9a68850cb398665cf78b31de6"
+
+S = "${WORKDIR}/git"
+
+inherit autotools-brokensep ptest
+
+COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/cron.hourly
+ install -m 0755 ${S}/mcelog.cron ${D}${sysconfdir}/cron.hourly/
+ sed -i 's/bash/sh/' ${D}${sysconfdir}/cron.hourly/mcelog.cron
+}
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}
+ cp -r ${S}/tests ${S}/input ${D}${PTEST_PATH}
+ sed -i 's#../../mcelog#mcelog#' ${D}${PTEST_PATH}/tests/test
+}
+
+RDEPENDS_${PN}-ptest += "make bash mce-inject"