summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-bsp
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2021-08-06 20:35:36 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-11 20:28:12 +0300
commit8c6707f0dcab30d2c0d818b455b030b5d7e7091c (patch)
treee6d72dfc25e2769c7c6ea93c064af0970d8f3c7e /meta-openpower/recipes-bsp
parentf3acf6db3a6e527a4c8347643924fbc33c65e237 (diff)
downloadopenbmc-8c6707f0dcab30d2c0d818b455b030b5d7e7091c.tar.xz
meta-openpower: prep for new override syntax
Change-Id: I5ca16c6fa7bc616bfa9bc41c4f86d32fd92b0287 Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
Diffstat (limited to 'meta-openpower/recipes-bsp')
-rw-r--r--meta-openpower/recipes-bsp/ecmd/croserver_git.bb2
-rw-r--r--meta-openpower/recipes-bsp/ecmd/libecmd_git.bb8
-rw-r--r--meta-openpower/recipes-bsp/ffs/ffs.inc6
-rw-r--r--meta-openpower/recipes-bsp/ipl/ipl_git.bb2
-rw-r--r--meta-openpower/recipes-bsp/pdata/phal-devtree.bb2
-rw-r--r--meta-openpower/recipes-bsp/skiboot/gard_git.bb2
-rw-r--r--meta-openpower/recipes-bsp/skiboot/pflash_git.bb2
-rw-r--r--meta-openpower/recipes-bsp/skiboot/skiboot.inc6
8 files changed, 15 insertions, 15 deletions
diff --git a/meta-openpower/recipes-bsp/ecmd/croserver_git.bb b/meta-openpower/recipes-bsp/ecmd/croserver_git.bb
index e1aa88e510..cdd244e9cd 100644
--- a/meta-openpower/recipes-bsp/ecmd/croserver_git.bb
+++ b/meta-openpower/recipes-bsp/ecmd/croserver_git.bb
@@ -33,4 +33,4 @@ do_install() {
install -m 0644 ${WORKDIR}/croserver.service ${D}${systemd_system_unitdir}/
}
-FILES_${PN} += "${systemd_system_unitdir}/croserver.service"
+FILES:${PN} += "${systemd_system_unitdir}/croserver.service"
diff --git a/meta-openpower/recipes-bsp/ecmd/libecmd_git.bb b/meta-openpower/recipes-bsp/ecmd/libecmd_git.bb
index c2e43a4ce7..445dce2892 100644
--- a/meta-openpower/recipes-bsp/ecmd/libecmd_git.bb
+++ b/meta-openpower/recipes-bsp/ecmd/libecmd_git.bb
@@ -51,11 +51,11 @@ do_install() {
PARALLEL_MAKE = ""
# ecmd doesn't have proper library versioning
-FILES_${PN}-dev_remove = "${libdir}/lib*.so"
-FILES_${PN} += "${libdir}/lib*.so"
+FILES:${PN}-dev:remove = "${libdir}/lib*.so"
+FILES:${PN} += "${libdir}/lib*.so"
-RDEPENDS_${PN}-bin = "libecmd"
+RDEPENDS:${PN}-bin = "libecmd"
# This allows someone to easily use ecmd bins, even if you don’t want them.
PACKAGE_BEFORE_PN = "libecmd-bin"
-FILES_${PN}-bin += "${bindir}"
+FILES:${PN}-bin += "${bindir}"
diff --git a/meta-openpower/recipes-bsp/ffs/ffs.inc b/meta-openpower/recipes-bsp/ffs/ffs.inc
index f144884aa8..f9b651159a 100644
--- a/meta-openpower/recipes-bsp/ffs/ffs.inc
+++ b/meta-openpower/recipes-bsp/ffs/ffs.inc
@@ -8,10 +8,10 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
inherit autotools pkgconfig
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
PACKAGE_BEFORE_PN += "${PN}-ecc ${PN}-deprecated"
-FILES_${PN}-ecc = "${bindir}/ecc"
-FILES_${PN}-deprecated = "${bindir}"
+FILES:${PN}-ecc = "${bindir}/ecc"
+FILES:${PN}-deprecated = "${bindir}"
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-openpower/recipes-bsp/ipl/ipl_git.bb b/meta-openpower/recipes-bsp/ipl/ipl_git.bb
index edd44bc781..003b7fb508 100644
--- a/meta-openpower/recipes-bsp/ipl/ipl_git.bb
+++ b/meta-openpower/recipes-bsp/ipl/ipl_git.bb
@@ -18,6 +18,6 @@ DEPENDS = " \
libekb pdbg autoconf-archive guard \
"
-RDEPENDS_${PN} = "phal-devtree"
+RDEPENDS:${PN} = "phal-devtree"
EXTRA_OECONF = "CHIP=p10"
diff --git a/meta-openpower/recipes-bsp/pdata/phal-devtree.bb b/meta-openpower/recipes-bsp/pdata/phal-devtree.bb
index 4ad477ae4a..03f7f02ca6 100644
--- a/meta-openpower/recipes-bsp/pdata/phal-devtree.bb
+++ b/meta-openpower/recipes-bsp/pdata/phal-devtree.bb
@@ -8,7 +8,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
PDATA_DTB_PATH="${datadir}/pdata"
-FILES_${PN} += "${PDATA_DTB_PATH}"
+FILES:${PN} += "${PDATA_DTB_PATH}"
do_install() {
diff --git a/meta-openpower/recipes-bsp/skiboot/gard_git.bb b/meta-openpower/recipes-bsp/skiboot/gard_git.bb
index 214e905ef0..49d86602de 100644
--- a/meta-openpower/recipes-bsp/skiboot/gard_git.bb
+++ b/meta-openpower/recipes-bsp/skiboot/gard_git.bb
@@ -2,4 +2,4 @@ SUMMARY = "gard record tool for OpenPower"
DESCRIPTION = "gard record tool for OpenPower machines"
require skiboot.inc
-EXTRA_OEMAKE_append = " PFLASH_VERSION=${PV} GARD_VERSION=${PV}"
+EXTRA_OEMAKE:append = " PFLASH_VERSION=${PV} GARD_VERSION=${PV}"
diff --git a/meta-openpower/recipes-bsp/skiboot/pflash_git.bb b/meta-openpower/recipes-bsp/skiboot/pflash_git.bb
index 05aa2fccab..e30cad5633 100644
--- a/meta-openpower/recipes-bsp/skiboot/pflash_git.bb
+++ b/meta-openpower/recipes-bsp/skiboot/pflash_git.bb
@@ -2,7 +2,7 @@ SUMMARY = "pflash programmer for OpenPower"
DESCRIPTION = "pflash firmware programming tool for OpenPower machines"
require skiboot.inc
-EXTRA_OEMAKE_append = " PFLASH_VERSION=${PV} LINKAGE=dynamic"
+EXTRA_OEMAKE:append = " PFLASH_VERSION=${PV} LINKAGE=dynamic"
#TODO: openbmc/openbmc#1361 - Fix GNU_HASH warnings in pflash
TARGET_CC_ARCH += "${LDFLAGS}"
diff --git a/meta-openpower/recipes-bsp/skiboot/skiboot.inc b/meta-openpower/recipes-bsp/skiboot/skiboot.inc
index 7140c64325..4f3791266d 100644
--- a/meta-openpower/recipes-bsp/skiboot/skiboot.inc
+++ b/meta-openpower/recipes-bsp/skiboot/skiboot.inc
@@ -3,7 +3,7 @@ LICENSE = "Apache-2.0"
SRC_URI += "git://github.com/open-power/skiboot.git;branch=skiboot-6.5.x"
-FILESEXTRAPATHS_prepend := "${THISDIR}/skiboot:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/skiboot:"
LIC_FILES_CHKSUM = "file://${S}/LICENCE;md5=3b83ef96387f14655fc854ddc3c6bd57"
@@ -27,6 +27,6 @@ do_install() {
}
# libflash.so is a SONAME and is strongly required in the production
-INSANE_SKIP_${PN}_append = "dev-so"
+INSANE_SKIP:${PN}:append = "dev-so"
FILES_SOLIBSDEV = ""
-FILES_${PN}_append = " ${libdir}/libflash.so"
+FILES:${PN}:append = " ${libdir}/libflash.so"