summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2021-06-24 23:28:47 +0300
committerAndrew Geissler <geissonator@yahoo.com>2021-07-09 04:02:37 +0300
commit4d2fd8d96ab318d4b18b8c24dabd41b49e844856 (patch)
tree2634b5e87bbd11777c5e9c6190e7871b0000de6c /meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
parenta3f1796232b5bfa74cb081ee334bbf520b9b828d (diff)
downloadopenbmc-4d2fd8d96ab318d4b18b8c24dabd41b49e844856.tar.xz
op-proc-control: bmc reset host status check
Enable the new BMC function to look at a CFAM register as a last chance to see if the host is running. See the following for more detail: https://github.com/openbmc/docs/blob/master/designs/bmc-reset-with-host-up.md#note-on-custom-mechanism-for-ibm-systems openpower-proc-control: srcrev bump f8c14bcfd5..3292c0676e Andrew Geissler (8): service-files: move to own sub-directory primary-proc: move function to common utils bmc-reset: check if host is running bmc-reset: ensure error is created if host up bmc-reset: call new host reset check service bmc-reset: add support to write a cfam bmc-reset: add support to clear host running register bmc-reset: call new clear host running status service Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: If4f7c3a7a58bbe5c7fda09bdc949ed31f5cb1cbf
Diffstat (limited to 'meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb')
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
index 7ce65f9278..c0132b80ce 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -57,6 +57,10 @@ pkg_postinst_${PN}() {
LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.requires/proc-pre-poweroff@0.service"
TARGET="../proc-pre-poweroff@.service"
ln -s $TARGET $LINK
+
+ LINK="$D$systemd_system_unitdir/obmc-host-reset@0.target.requires/op-reset-host-check@0.service"
+ TARGET="../op-reset-host-check@.service"
+ ln -s $TARGET $LINK
fi
# If the memory preserving reboot feature is enabled, set it up