summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-02-18 00:11:03 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-03-16 18:50:35 +0300
commit82cfa666a8eaea5cd8f0bca9a13113ad8b949190 (patch)
tree3b1b06a5a57e458e527031768f3c2e4818b16c6a /meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
parent0989ba28bbe71cb62f6859b7493e193696835221 (diff)
downloadopenbmc-82cfa666a8eaea5cd8f0bca9a13113ad8b949190.tar.xz
warm-reboot: stop instr and cfam reset
Install the new stop instructions and cfam reset services required for a warm reboot into the appropriate target Includes following in bump: Andrew Geissler (4): warm-reboot: ensure sbe start bit is 0 warm reboot: stop instructions support warm-reboot: add cfam-reset capabilities warm-reboot: cfam-reset service (From meta-openpower rev: 84962a9850f8f7b61698134ecf2d016a9b1e33de) Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: Ia8fe30f160e0078bbdca2bcef322c9e23ea0e9e0 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb')
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
new file mode 100644
index 0000000000..cd4f63baec
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -0,0 +1,32 @@
+SUMMARY = "OpenPOWER processor control services installation"
+PR = "r1"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit allarch
+
+RDEPENDS_${PN} += "op-proc-control"
+RDEPENDS_${PN} += "phosphor-state-manager-obmc-targets"
+
+ALLOW_EMPTY_${PN} = "1"
+
+pkg_postinst_${PN}() {
+ mkdir -p $D$systemd_system_unitdir/obmc-host-stop@0.target.requires
+ mkdir -p $D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires
+
+ LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.requires/op-stop-instructions@0.service"
+ TARGET="../op-stop-instructions@.service"
+ ln -s $TARGET $LINK
+
+ LINK="$D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires/op-cfam-reset.service"
+ TARGET="../op-cfam-reset.service"
+ ln -s $TARGET $LINK
+}
+
+pkg_prerm_${PN}() {
+ LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.requires/op-stop-instructions@0.service"
+ rm $LINK
+ LINK="$D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires/op-cfam-reset.service"
+ rm $LINK
+}