summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
diff options
context:
space:
mode:
authorDhruvaraj Subhashchandran <dhruvaraj@in.ibm.com>2020-03-09 21:04:32 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-04-17 01:55:29 +0300
commitc8aa6a1dd361328fa529f7bab2fe53317a541329 (patch)
treefecb51d996a11158788aab2a913353835c69e28b /meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
parent37069179d17072e65f7a4ea06a66f29e7eea26ed (diff)
downloadopenbmc-c8aa6a1dd361328fa529f7bab2fe53317a541329.tar.xz
Memory preserve reboot: recipe updates for mpreboot.
start_host@.service: Update to start_host service to skip it during a memory preserve reboot op-proc-control-systemd-links.bb: update to install services op-proc-control_git.bb: Added mpreboot services Bump openpower-proc-control SRCREV to required commit (From meta-openpower rev: 7e0062d06c12e177f6a767a1c21066dc30ecae44) Signed-off-by: Dhruvaraj Subhashchandran <dhruvaraj@in.ibm.com> Change-Id: Ib2e3e34f3faa1ad575def9b26ff3e91d5eebf93f Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb')
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
index 8185ddf8f3..46fdbbcb9f 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -14,6 +14,8 @@ ALLOW_EMPTY_${PN} = "1"
pkg_postinst_${PN}() {
mkdir -p $D$systemd_system_unitdir/obmc-host-stop@0.target.wants
mkdir -p $D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires
+ mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.requires
+ mkdir -p $D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires
LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service"
TARGET="../op-stop-instructions@.service"
@@ -30,6 +32,14 @@ pkg_postinst_${PN}() {
TARGET="../cfam_override@.service"
ln -s $TARGET $LINK
fi
+
+ LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-continue-mpreboot@0.service"
+ TARGET="../op-continue-mpreboot@.service"
+ ln -s $TARGET $LINK
+
+ LINK="$D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires/op-enter-mpreboot@0.service"
+ TARGET="../op-enter-mpreboot@.service"
+ ln -s $TARGET $LINK
}
pkg_prerm_${PN}() {
@@ -42,4 +52,8 @@ pkg_prerm_${PN}() {
LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/cfam_override@0.service"
rm $LINK
fi
+ LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-continue-mpreboot@0.service"
+ rm $LINK
+ LINK="$D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires/op-enter-mpreboot@0.service"
+ rm $LINK
}