summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor
diff options
context:
space:
mode:
authorJayanth Othayoth <ojayanth@in.ibm.com>2022-09-12 14:23:45 +0300
committerJayanth Othayoth <ojayanth@in.ibm.com>2022-09-13 20:15:22 +0300
commit633a9cc2d931d96e0c8a19b7318a905ea011aa11 (patch)
tree7ace5371cc3da30b05eb4ab5f64ce4f04e4fa827 /meta-openpower/recipes-phosphor
parente82d1879b4c332b34171becec1e1d37407b8cbc5 (diff)
downloadopenbmc-633a9cc2d931d96e0c8a19b7318a905ea011aa11.tar.xz
openpower-proc-control: srcrev bump ed7fb7aee3..1af14431aa
Jayanth Othayoth (3): PHAL: Added processor CFAM register data in the clock daily data logger PHAL: Added clock register data in the clock daily data logger PHAL: add clock data logger service Also Enabled clock data logger service. This service is to create informational log daily, which includes clock register data. This data is used for clock failure debug. This service will start after start host completion. Tested: verified service installation manually Signed-off-by: Jayanth Othayoth <ojayanth@in.ibm.com> Change-Id: Idbf8314b8ad4e48626ec5f28769a6105c6438526
Diffstat (limited to 'meta-openpower/recipes-phosphor')
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb8
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control_git.bb3
2 files changed, 10 insertions, 1 deletions
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
index 8dce7b0e61..50c9baf9dd 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -86,6 +86,11 @@ pkg_postinst:${PN}() {
ln -s $TARGET $LINK
LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/phal-create-boottime-guard-indicator.service"
ln -s $TARGET $LINK
+
+ mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.wants
+ LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/op-clock-data-logger@0.service"
+ TARGET="../op-clock-data-logger@.service"
+ ln -s $TARGET $LINK
fi
# If the memory preserving reboot feature is enabled, set it up
@@ -147,6 +152,9 @@ pkg_prerm:${PN}() {
rm $LINK
LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/phal-create-boottime-guard-indicator.service"
rm $LINK
+
+ LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/op-clock-data-logger@0.service"
+ rm $LINK
fi
# Remove mpreboot specific units if enabled
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index 0472d2cdf4..966e4f7733 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -11,7 +11,7 @@ inherit meson obmc-phosphor-utils pkgconfig
inherit systemd
SRC_URI += "git://github.com/openbmc/openpower-proc-control;branch=master;protocol=https"
-SRCREV = "ed7fb7aee34661d65dc0455316e68d90a36d75fb"
+SRCREV = "1af14431aab1193c2ec636989aa7db7ef283c8b7"
DEPENDS += " \
phosphor-logging \
@@ -52,4 +52,5 @@ SYSTEMD_SERVICE:${PN} += " \
${@bb.utils.contains('MACHINE_FEATURES', 'phal', 'set-spi-mux.service', '', d)} \
${@bb.utils.contains('MACHINE_FEATURES', 'phal', 'phal-create-boottime-guard-indicator.service', '', d)} \
${@bb.utils.contains('MACHINE_FEATURES', 'phal', 'op-clear-sys-dump-active@.service', '', d)} \
+ ${@bb.utils.contains('MACHINE_FEATURES', 'phal', 'op-clock-data-logger@.service', '', d)} \
"