summaryrefslogtreecommitdiff
path: root/meta-openpower
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2022-05-23 22:53:39 +0300
committerAndrew Geissler <andrew@geissonator.com>2022-08-30 21:25:37 +0300
commit07f6ad025d1a4c690a0259f1ac567c9b54e90f5b (patch)
tree14bc8d7e2843c95c32c76f29be1abc5a3464e43a /meta-openpower
parent6058204944d63ceb8471b919021251fc36c6797d (diff)
downloadopenbmc-07f6ad025d1a4c690a0259f1ac567c9b54e90f5b.tar.xz
meta-ibm: add phal machine feature checks
The p10bmc machines require the phal and op-fsi features to be enabled to function properly. Tested: - Confirmed both features enabled on p10bmc machine - Confirmed only op-fsi was enabled on witherspoon Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: Id01cae6246204a025f4401d0d2c26ccda78d7d77
Diffstat (limited to 'meta-openpower')
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control_git.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index ad66ab4b69..90c50fc506 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -24,6 +24,13 @@ EXTRA_OEMESON += "-Dtests=disabled"
# For libpdbg, provided by the pdbg package
DEPENDS += "pdbg"
+PACKAGECONFIG ??= "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal op-fsi', d)}"
+PACKAGECONFIG[phal] = "-Dphal=enabled, -Dphal=disabled -Dp9=enabled, ipl pdata"
+PACKAGECONFIG[op-fsi] = "-Dopenfsi=enabled, -Dopenfsi=disabled"
+
+# By default all openpower systems support op-fsi
+PACKAGECONFIG = " op-fsi"
+
TEMPLATE = "pcie-poweroff@.service"
INSTANCE_FORMAT = "pcie-poweroff@{}.service"
INSTANCES = "${@compose_list(d, 'INSTANCE_FORMAT', 'OBMC_CHASSIS_INSTANCES')}"