summaryrefslogtreecommitdiff
path: root/meta-openpower
diff options
context:
space:
mode:
authorSantosh Puranik <santosh.puranik@in.ibm.com>2020-03-10 12:31:38 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-08-21 02:00:11 +0300
commit24ed9c7fcc5bd79b7d69b6d725816fb5eace6e08 (patch)
tree387755a9dbea3a87b33d15f4581d840fe8a3cc5a /meta-openpower
parent2c27ef74ddf77bc737c61a566361037d303bb298 (diff)
downloadopenbmc-24ed9c7fcc5bd79b7d69b6d725816fb5eace6e08.tar.xz
Move OpenPower VPD Parser to Meson
This commit moves the openpower-fru-vpd recipe to use meson instead of autotools. Tested: Tested in conjunction with openpower-vpd-parser master. Builds and runs fine. (From meta-openpower rev: 08d415a4e7501805b26f33d650fb550d6e7ed034) Signed-off-by: Santosh Puranik <santosh.puranik@in.ibm.com> Change-Id: Ic1ce24c8b1382294cfed5b682d52fa27b2cce441 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-openpower')
-rw-r--r--meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd_git.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd_git.bb b/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd_git.bb
index b82ae84da9..da31ab9064 100644
--- a/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd_git.bb
+++ b/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd_git.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Parse OpenPOWER-format FRU VPD and update inventory"
PR = "r1"
PV = "1.0+git${SRCPV}"
-inherit autotools pkgconfig
+inherit meson pkgconfig
inherit openpower-fru-vpd
inherit python3native
inherit obmc-phosphor-systemd
@@ -27,9 +27,10 @@ SYSTEMD_SERVICE_${PN} += "op-vpd-parser.service"
S = "${WORKDIR}/git"
-EXTRA_OECONF = " \
- FRU_YAML=${STAGING_DIR_NATIVE}${vpdlayout_datadir}/layout.yaml \
- PROP_YAML=${STAGING_DIR_NATIVE}${properties_datadir}/out.yaml \
+EXTRA_OEMESON = " \
+ -Dtests=disabled \
+ -DFRU_YAML=${STAGING_DIR_NATIVE}${vpdlayout_datadir}/layout.yaml \
+ -DPROP_YAML=${STAGING_DIR_NATIVE}${properties_datadir}/out.yaml \
"
do_install_append() {