summaryrefslogtreecommitdiff
path: root/meta-openpower
diff options
context:
space:
mode:
authorAndrew Geissler <openbmcbump-github@yahoo.com>2023-05-12 22:10:34 +0300
committerAndrew Geissler <geissonator@yahoo.com>2023-05-17 04:04:40 +0300
commitb9b3a4a989b6e08c01a49800e54ad3d692413062 (patch)
tree3d953d4eb885eb13d47e4d0e3599c0dc110ccb5b /meta-openpower
parent3f7c8bbab7395a07b140c0fc1387da76312a6d7c (diff)
downloadopenbmc-b9b3a4a989b6e08c01a49800e54ad3d692413062.tar.xz
openpower-proc-control: srcrev bump 00dd33efc3..933bee764b
Andrew Geissler (1): systemd: no installation in templated targets Includes the needed changes to install services in appropriate targets. Change-Id: I3c9fbbc5dd0ad73ded05858476b71d0c6eccff6c Signed-off-by: Andrew Geissler <openbmcbump-github@yahoo.com>
Diffstat (limited to 'meta-openpower')
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb15
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control_git.bb4
2 files changed, 18 insertions, 1 deletions
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
index 50c9baf9dd..14d64320fa 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -15,6 +15,7 @@ pkg_postinst:${PN}() {
mkdir -p $D$systemd_system_unitdir/obmc-host-stop@0.target.wants
mkdir -p $D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires
mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.requires
+ mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.wants
mkdir -p $D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires
mkdir -p $D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires
mkdir -p $D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants
@@ -31,6 +32,10 @@ pkg_postinst:${PN}() {
TARGET="../op-cfam-reset.service"
ln -s $TARGET $LINK
+ LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/xyz.openbmc_project.Control.Host.NMI.service"
+ TARGET="../xyz.openbmc_project.Control.Host.NMI.service"
+ ln -s $TARGET $LINK
+
LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires/op-cfam-reset.service"
TARGET="../op-cfam-reset.service"
ln -s $TARGET $LINK
@@ -91,6 +96,11 @@ pkg_postinst:${PN}() {
LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/op-clock-data-logger@0.service"
TARGET="../op-clock-data-logger@.service"
ln -s $TARGET $LINK
+
+ mkdir -p $D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.wants
+ LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.wants/set-spi-mux.service"
+ TARGET="../set-spi-mux.service"
+ ln -s $TARGET $LINK
fi
# If the memory preserving reboot feature is enabled, set it up
@@ -126,6 +136,8 @@ pkg_prerm:${PN}() {
rm $LINK
LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires/op-cfam-reset.service"
rm $LINK
+ LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/xyz.openbmc_project.Control.Host.NMI.service"
+ rm $LINK
# Only uninstall cfam override if p9 system
if [ "${@bb.utils.contains("MACHINE_FEATURES", "p9-cfam-override", "True", "False", d)}" = True ]; then
LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/cfam_override@0.service"
@@ -142,6 +154,9 @@ pkg_prerm:${PN}() {
LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.requires/proc-pre-poweroff@0.service"
rm $LINK
+ LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.wants/set-spi-mux.service"
+ rm $LINK
+
LINK="$D$systemd_system_unitdir/multi-user.target.wants/phal-import-devtree@0.service"
rm $LINK
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index b2b3227db0..8cd1a4a8dd 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -11,7 +11,7 @@ inherit meson obmc-phosphor-utils pkgconfig
inherit systemd
SRC_URI = "git://github.com/openbmc/openpower-proc-control;branch=master;protocol=https"
-SRCREV = "00dd33efc3a2f32aabb3981c81f64ad238716ce0"
+SRCREV = "933bee764b2a0b796064fb94496dd45c539bd3f0"
DEPENDS += " \
phosphor-logging \
@@ -19,6 +19,8 @@ DEPENDS += " \
libgpiod \
"
+RDEPENDS:${PN} += " op-proc-control-systemd-links"
+
EXTRA_OEMESON += "-Dtests=disabled"
# For libpdbg, provided by the pdbg package