summaryrefslogtreecommitdiff
path: root/meta-phosphor/classes
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2020-04-02 01:23:22 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-04-07 02:47:02 +0300
commitc638701050de4c8f9243fae2aa388f49131273b8 (patch)
tree0a4b42e53ddec3209b64aa887c0dbe17337c1123 /meta-phosphor/classes
parent147a795bfabe5c16a211447643bbfeac9c57c1f9 (diff)
downloadopenbmc-c638701050de4c8f9243fae2aa388f49131273b8.tar.xz
meta-phosphor: remove unused config-in-skeleton bbclass
(From meta-phosphor rev: 501bea332a71385297c2968a16e6782ce96cf5e5) Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I39a6f05d2180e4965c8767b441743bb66b5a2f07 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/classes')
-rw-r--r--meta-phosphor/classes/config-in-skeleton.bbclass36
1 files changed, 0 insertions, 36 deletions
diff --git a/meta-phosphor/classes/config-in-skeleton.bbclass b/meta-phosphor/classes/config-in-skeleton.bbclass
deleted file mode 100644
index b767537244..0000000000
--- a/meta-phosphor/classes/config-in-skeleton.bbclass
+++ /dev/null
@@ -1,36 +0,0 @@
-# In general this class should only be used by board layers
-# that keep their machine-readable-workbook in the skeleton repository.
-
-inherit allarch
-inherit setuptools
-inherit pythonnative
-inherit skeleton-rev
-
-HOMEPAGE = "http://github.com/openbmc/skeleton"
-
-PROVIDES += "virtual/obmc-inventory-data"
-RPROVIDES_${PN} += "virtual-obmc-inventory-data"
-
-DEPENDS += "python"
-SRC_URI += "${SKELETON_URI};"
-S = "${WORKDIR}/git/configs"
-
-python() {
- machine = d.getVar('MACHINE', True).capitalize() + '.py'
- d.setVar('_config_in_skeleton', machine)
-}
-
-do_make_setup() {
- cp ${S}/${_config_in_skeleton} \
- ${S}/obmc_system_config.py
- cat <<EOF > ${S}/setup.py
-from distutils.core import setup
-
-setup(name='${BPN}',
- version='${PR}',
- py_modules=['obmc_system_config'],
- )
-EOF
-}
-
-addtask make_setup after do_patch before do_configure