summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-core/dropbear
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@us.ibm.com>2015-12-02 20:10:56 +0300
committerBrad Bishop <bradleyb@us.ibm.com>2015-12-02 20:12:45 +0300
commit78a2726af43f91e193db34c6b2b9f53f148df0ce (patch)
tree0df7b1dc352e36cd12dd69b2b85ef32c885a7ca5 /meta-phosphor/common/recipes-core/dropbear
parentbfd86fd1c1b19d9fea36e18b4b23f2ab2d45f941 (diff)
downloadopenbmc-78a2726af43f91e193db34c6b2b9f53f148df0ce.tar.xz
Set dropbearkey service to start on boot
Before this patch it isn't started until the first client connection which is not the desired behavior.
Diffstat (limited to 'meta-phosphor/common/recipes-core/dropbear')
-rw-r--r--meta-phosphor/common/recipes-core/dropbear/dropbear/dropbearkey.service11
-rw-r--r--meta-phosphor/common/recipes-core/dropbear/dropbear_%.bbappend2
2 files changed, 13 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-core/dropbear/dropbear/dropbearkey.service b/meta-phosphor/common/recipes-core/dropbear/dropbear/dropbearkey.service
new file mode 100644
index 0000000000..623f73e42d
--- /dev/null
+++ b/meta-phosphor/common/recipes-core/dropbear/dropbear/dropbearkey.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=SSH Key Generation
+ConditionPathExists=|!/etc/dropbear/dropbear_rsa_host_key
+
+[Service]
+Type=oneshot
+ExecStart=@SBINDIR@/dropbearkey -t rsa -f /etc/dropbear/dropbear_rsa_host_key
+RemainAfterExit=yes
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-phosphor/common/recipes-core/dropbear/dropbear_%.bbappend b/meta-phosphor/common/recipes-core/dropbear/dropbear_%.bbappend
new file mode 100644
index 0000000000..36c0dcd122
--- /dev/null
+++ b/meta-phosphor/common/recipes-core/dropbear/dropbear_%.bbappend
@@ -0,0 +1,2 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+SRC_URI += "file://dropbearkey.service"