summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-phosphor/chassis
diff options
context:
space:
mode:
authorSaqib Khan <khansa@us.ibm.com>2017-11-13 19:47:54 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2017-11-27 21:39:58 +0300
commit02917dfec4663c832803b9f242dd2628f3207ca6 (patch)
treed906ace8c8f132eb0a2880fc6a4f9144b21cc912 /meta-phosphor/common/recipes-phosphor/chassis
parent5c933bada6bc2f8c1e34f2553206e26819cf26d9 (diff)
downloadopenbmc-02917dfec4663c832803b9f242dd2628f3207ca6.tar.xz
Add required package "pkgconfig"
This package is required for the following receipes in yocto-2.3. Otherwise we get the error: "fatal error: gio/gio.h: No such file or directory" Change-Id: I020c8f31d707da716956b7856ba14076294bd7c7 Signed-off-by: Saqib Khan <khansa@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/chassis')
-rw-r--r--meta-phosphor/common/recipes-phosphor/chassis/obmc-button-power.bb1
-rw-r--r--meta-phosphor/common/recipes-phosphor/chassis/obmc-button-reset.bb1
-rw-r--r--meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power.bb1
-rw-r--r--meta-phosphor/common/recipes-phosphor/chassis/obmc-pcie-detect.bb1
4 files changed, 4 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/chassis/obmc-button-power.bb b/meta-phosphor/common/recipes-phosphor/chassis/obmc-button-power.bb
index db995e1007..144d4e1e7d 100644
--- a/meta-phosphor/common/recipes-phosphor/chassis/obmc-button-power.bb
+++ b/meta-phosphor/common/recipes-phosphor/chassis/obmc-button-power.bb
@@ -4,6 +4,7 @@ PR = "r1"
inherit skeleton-gdbus
inherit obmc-phosphor-dbus-service
+inherit pkgconfig
SKELETON_DIR = "pwrbutton"
diff --git a/meta-phosphor/common/recipes-phosphor/chassis/obmc-button-reset.bb b/meta-phosphor/common/recipes-phosphor/chassis/obmc-button-reset.bb
index 802e49909b..9435d31413 100644
--- a/meta-phosphor/common/recipes-phosphor/chassis/obmc-button-reset.bb
+++ b/meta-phosphor/common/recipes-phosphor/chassis/obmc-button-reset.bb
@@ -4,6 +4,7 @@ PR = "r1"
inherit skeleton-gdbus
inherit obmc-phosphor-dbus-service
+inherit pkgconfig
SKELETON_DIR = "rstbutton"
diff --git a/meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power.bb b/meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power.bb
index 4388e7a7b9..5dd6d12cf8 100644
--- a/meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power.bb
+++ b/meta-phosphor/common/recipes-phosphor/chassis/obmc-op-control-power.bb
@@ -4,6 +4,7 @@ PR = "r1"
inherit skeleton-gdbus
inherit obmc-phosphor-dbus-service
+inherit pkgconfig
DEPENDS += "phosphor-mapper systemd"
diff --git a/meta-phosphor/common/recipes-phosphor/chassis/obmc-pcie-detect.bb b/meta-phosphor/common/recipes-phosphor/chassis/obmc-pcie-detect.bb
index b0709587ad..6b5761b5e7 100644
--- a/meta-phosphor/common/recipes-phosphor/chassis/obmc-pcie-detect.bb
+++ b/meta-phosphor/common/recipes-phosphor/chassis/obmc-pcie-detect.bb
@@ -4,6 +4,7 @@ PR = "r1"
inherit skeleton-gdbus
inherit obmc-phosphor-systemd
+inherit pkgconfig
SKELETON_DIR = "pciedetect"