summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-phosphor/datetime
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-01-25 00:17:40 +0300
committerPatrick Williams <patrick@stwcx.xyz>2017-01-26 06:43:06 +0300
commitfc0e7e412f2bbd4f251725735bfba054c80b28c8 (patch)
tree19b479b081938770b446ac71b915a3dcac9d8755 /meta-phosphor/common/recipes-phosphor/datetime
parent2079009427ddcccfe684bc4977422d4c707086f9 (diff)
downloadopenbmc-fc0e7e412f2bbd4f251725735bfba054c80b28c8.tar.xz
Rename phosphor-time-manager to datetime
These directories: - Should not have a phosphor prefix. - Are groups of recipes organized by topic, not single applications. Change-Id: I637f5710fee04872205c5dc555d81c08d8a076cb Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/datetime')
-rw-r--r--meta-phosphor/common/recipes-phosphor/datetime/phosphor-time-manager.bb23
-rw-r--r--meta-phosphor/common/recipes-phosphor/datetime/phosphor-time-manager/org.openbmc.TimeManager.service15
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/datetime/phosphor-time-manager.bb b/meta-phosphor/common/recipes-phosphor/datetime/phosphor-time-manager.bb
new file mode 100644
index 0000000000..54f89ba730
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/datetime/phosphor-time-manager.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Phosphor Time Manager daemon"
+DESCRIPTION = "Daemon to cater to BMC and HOST time management"
+HOMEPAGE = "http://github.com/openbmc/phosphor-time-manager"
+PR = "r1"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+inherit autotools pkgconfig
+inherit obmc-phosphor-dbus-service
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "phosphor-mapper"
+DEPENDS += "systemd"
+RDEPENDS_${PN} += "virtual-obmc-settings-mgmt"
+RDEPENDS_${PN} += "network"
+RDEPENDS_${PN} += "libmapper"
+RDEPENDS_${PN} += "libsystemd"
+
+SRC_URI += "git://github.com/openbmc/phosphor-time-manager"
+SRCREV = "2a96cfc0ed4e5466793a82292ee5640c992b963c"
+S = "${WORKDIR}/git"
+
+DBUS_SERVICE_${PN} += "org.openbmc.TimeManager.service"
diff --git a/meta-phosphor/common/recipes-phosphor/datetime/phosphor-time-manager/org.openbmc.TimeManager.service b/meta-phosphor/common/recipes-phosphor/datetime/phosphor-time-manager/org.openbmc.TimeManager.service
new file mode 100644
index 0000000000..a7c316255f
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/datetime/phosphor-time-manager/org.openbmc.TimeManager.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Phosphor Time Manager daemon
+Wants=mapper-wait@-org-openbmc-NetworkManager-Interface.service
+After=mapper-wait@-org-openbmc-NetworkManager-Interface.service
+Wants=mapper-wait@-org-openbmc-settings-host0.service
+After=mapper-wait@-org-openbmc-settings-host0.service
+
+[Service]
+Restart=always
+ExecStart={sbindir}/timemanager
+Type=dbus
+BusName={BUSNAME}
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}