summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-phosphor/fans/obmc-control-fan.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2016-09-06 19:22:28 +0300
committerPatrick Williams <patrick@stwcx.xyz>2016-09-12 21:45:18 +0300
commitdbb9856f262618b8039890b5f7f9a95e68e6c312 (patch)
treeda708793f8104e01bf1b98ad12cc582240754dae /meta-phosphor/common/recipes-phosphor/fans/obmc-control-fan.bb
parent194b590eb913cc8463c2c7774865d6bc8b07aa17 (diff)
downloadopenbmc-dbb9856f262618b8039890b5f7f9a95e68e6c312.tar.xz
Drop obmc-phosphor- prefix from recipe collections
Given that these are already in the recipes-phosphor directory this seemed redundant. Change-Id: I48a1ab79e0eda88fc5e6af88f198ca3941e829b8 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/fans/obmc-control-fan.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/fans/obmc-control-fan.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/fans/obmc-control-fan.bb b/meta-phosphor/common/recipes-phosphor/fans/obmc-control-fan.bb
new file mode 100644
index 0000000000..256f9fc20b
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/fans/obmc-control-fan.bb
@@ -0,0 +1,15 @@
+SUMMARY = "OpenBMC fan control"
+DESCRIPTION = "OpenBMC fan control."
+PR = "r1"
+
+inherit skeleton-python
+inherit obmc-phosphor-dbus-service
+
+RDEPENDS_${PN} += "\
+ python-dbus \
+ python-pygobject \
+ pyphosphor-dbus \
+ "
+SKELETON_DIR = "pyfanctl"
+DBUS_SERVICE_${PN} += "org.openbmc.control.Fans.service"
+SYSTEMD_SERVICE_${PN} += "obmc-max-fans.service"