summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config-native.bb
diff options
context:
space:
mode:
authorGunnar Mills <gmills@us.ibm.com>2017-06-26 19:35:38 +0300
committerGunnar Mills <gmills@us.ibm.com>2017-06-27 22:14:13 +0300
commitc8228da1ec4e5615fdb26ef537309d6b4f01818d (patch)
tree79caa01c8455566082dae8c2283144f355b867cf /meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config-native.bb
parent88ffdbb9a56d243e21750c8fb639d40cc0095060 (diff)
downloadopenbmc-c8228da1ec4e5615fdb26ef537309d6b4f01818d.tar.xz
Install zone conditions yaml for fan control
Updated the fan control recipe files to include the zone conditions config yaml file. Change-Id: I5322cb397c2c58df4d6b2e9672ac28ed51e6be59 Signed-off-by: Gunnar Mills <gmills@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config-native.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config-native.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config-native.bb b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config-native.bb
new file mode 100644
index 0000000000..065efa5393
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config-native.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Phosphor zone conditions definition default data"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-fan
+
+SRC_URI += "file://zone_conditions.yaml"
+
+S = "${WORKDIR}"
+
+do_install() {
+ DEST=${D}${control_datadir}
+ install -D zone_conditions.yaml ${DEST}/zone_conditions.yaml
+}