summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-phosphor/host
diff options
context:
space:
mode:
authorJosh D. King <jdking@us.ibm.com>2017-04-06 23:56:37 +0300
committerPatrick Williams <patrick@stwcx.xyz>2017-04-20 18:43:45 +0300
commitefb04a1963ee03f7db756cb33ae52f024ffda086 (patch)
treed7dc1bf3dddc378580651944e965b256240fe15b /meta-phosphor/common/recipes-phosphor/host
parentb9ee536d0aae31718054ddad187a93d761d9dea2 (diff)
downloadopenbmc-efb04a1963ee03f7db756cb33ae52f024ffda086.tar.xz
Refactor action target names Host-start-stop
The target change is: obmc-chassis-stop -> obmc-host-stop obmc-chassis-start -> obmc-host-start Removed CHASSIS_FMT and CHASSIS_LINK_FMT because they are no longer needed. CHASSIS_POWER_FMT_2 did not change because its used for obmc-chassis-reset. Deleted files obmc-chassis-start@.target and obmc-chassis-stop@.target because they are no longer needed. I moved over their contents to obmc-host-start and obmc-host-stop. Updated phosphor-state-manager.bb and skeleton-rev.bbclass to have correct commit id. Change-Id: I26cba4153038f39d60e8d450a05969a216848abe Signed-off-by: Josh D. King <jdking@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/host')
-rw-r--r--meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host.bb2
-rw-r--r--meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host/op-reset-host-running@.service2
-rw-r--r--meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host/op-start-host@.service8
3 files changed, 6 insertions, 6 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host.bb b/meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host.bb
index fa5a006560..8533c8eabe 100644
--- a/meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host.bb
+++ b/meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host.bb
@@ -19,7 +19,7 @@ SYSTEMD_SERVICE_${PN} = " \
"
START_TMPL = "op-start-host@.service"
-START_TGTFMT = "obmc-chassis-start@{1}.target"
+START_TGTFMT = "obmc-host-start@{1}.target"
START_INSTFMT = "obmc-start-host@{0}.service"
START_FMT = "../${START_TMPL}:${START_TGTFMT}.requires/${START_INSTFMT}"
diff --git a/meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host/op-reset-host-running@.service b/meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host/op-reset-host-running@.service
index 7f3871efc1..9a6ffe60b9 100644
--- a/meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host/op-reset-host-running@.service
+++ b/meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host/op-reset-host-running@.service
@@ -7,7 +7,7 @@ ConditionPathExists=/run/openbmc/host@%i-on
[Service]
RemainAfterExit=no
# TODO: openbmc/openbmc#1205 - target name refactor
-ExecStart=/bin/systemctl start obmc-chassis-start@%i.target
+ExecStart=/bin/systemctl start obmc-host-start@%i.target
[Install]
diff --git a/meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host/op-start-host@.service b/meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host/op-start-host@.service
index 8c5cfbb5d7..c9d1a7c5c5 100644
--- a/meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host/op-start-host@.service
+++ b/meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host/op-start-host@.service
@@ -1,14 +1,14 @@
[Unit]
Description=Start Host%i
After=obmc-host-start-pre@%i.target
-Wants=obmc-host-start@%i.target
-Before=obmc-host-start@%i.target
+Wants=obmc-host-starting@%i.target
+Before=obmc-host-starting@%i.target
Before=obmc-host-started@%i.target
Wants=obmc-power-on@%i.target
After=obmc-power-on@%i.target
Wants=mapper-wait@-org-openbmc-control-host%i.service
After=mapper-wait@-org-openbmc-control-host%i.service
-Conflicts=obmc-chassis-stop@%i.target
+Conflicts=obmc-host-stop@%i.target
ConditionPathExists=!/run/openbmc/host@%i-on
[Service]
@@ -17,4 +17,4 @@ RemainAfterExit=yes
ExecStart={sbindir}/mapper call /org/openbmc/control/host%i org.openbmc.control.Host boot
[Install]
-WantedBy=obmc-chassis-start@%i.target
+WantedBy=obmc-host-start@%i.target