summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-phosphor/images
diff options
context:
space:
mode:
authorRick Altherr <raltherr@google.com>2016-12-08 23:21:49 +0300
committerPatrick Williams <patrick@stwcx.xyz>2016-12-19 16:35:47 +0300
commit4d9fd23f0e7e9fa5e72a805c6694471c38cf9dc6 (patch)
tree96764c0fcd1441d21663936b0030abb87d88c5d0 /meta-phosphor/common/recipes-phosphor/images
parent91eef023579b8806520789b9e770c9338c0622a2 (diff)
downloadopenbmc-4d9fd23f0e7e9fa5e72a805c6694471c38cf9dc6.tar.xz
Create a phosphor-specific initramfs
OpenBMC has been using a .bbappend to add/remove packages from core-image-minimal-initramfs. Doing so keeps the recipe and initramfs image name as core-image-minimal-initramfs which is misleading as it now is very much phosphor-specific. Instead, make a new obmc-phosphor-initramfs recipe and image that is patterned after core-image-minimal-initramfs. Change-Id: Ieca2268eff01bb61cc0d25a1cbc1a6f5fadb6d2c Signed-off-by: Rick Altherr <raltherr@google.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/images')
-rw-r--r--meta-phosphor/common/recipes-phosphor/images/obmc-phosphor-initramfs.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/images/obmc-phosphor-initramfs.bb b/meta-phosphor/common/recipes-phosphor/images/obmc-phosphor-initramfs.bb
new file mode 100644
index 0000000000..b68048a50d
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/images/obmc-phosphor-initramfs.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Small image capable of booting a device. The kernel includes \
+the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
+first 'init' program more efficiently."
+
+PACKAGE_INSTALL = "${VIRTUAL-RUNTIME_base-utils} udev base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} obmc-phosphor-initfs"
+
+# Do not pollute the initrd image with rootfs features
+IMAGE_FEATURES = ""
+
+export IMAGE_BASENAME = "obmc-phosphor-initramfs"
+IMAGE_LINGUAS = ""
+
+LICENSE = "MIT"
+
+IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
+inherit core-image
+
+IMAGE_ROOTFS_SIZE = "8192"
+IMAGE_ROOTFS_EXTRA_SPACE = "0"
+
+BAD_RECOMMENDATIONS += "busybox-syslog"