summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-properties-native.bb
diff options
context:
space:
mode:
authorRatan Gupta <ratagupt@in.ibm.com>2017-03-30 12:02:02 +0300
committerPatrick Williams <patrick@stwcx.xyz>2017-03-30 23:12:36 +0300
commit338899a5873c4c3ac6b9e907515f75ccb99a8cdc (patch)
treea8556917b3b0a21768f87be3636b6351c3924370 /meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-properties-native.bb
parent588b9f8c70dd7cbb2790539ed669f307dfb1efa5 (diff)
downloadopenbmc-338899a5873c4c3ac6b9e907515f75ccb99a8cdc.tar.xz
phosphor-ipmi-fru: rename the bb file
Rename the phosphor-ipmi-fru-properties-example-native to phosphor-ipmi-fru-properties-native. Rename the generated out.yaml to extra-properties.yaml. Change-Id: Id6fc1c6c5d30f58f7dd83305181d2b0372b2fb33 Signed-off-by: Ratan Gupta <ratagupt@in.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-properties-native.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-properties-native.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-properties-native.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-properties-native.bb
new file mode 100644
index 0000000000..8040f889d8
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-properties-native.bb
@@ -0,0 +1,22 @@
+SUMMARY = "FRU properties config for ipmi-fru-parser"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-ipmi-fru
+
+SRC_URI += "file://extra-properties.yaml"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-properties"
+
+S = "${WORKDIR}"
+
+do_install() {
+ # This recipe is supposed to create an output yaml file with
+ # FRU property values extracted from the MRW. This example recipe
+ # provides a sample output file.
+
+ DEST=${D}${properties_datadir}
+ install -d ${DEST}
+ install extra-properties.yaml ${DEST}
+}