summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb
diff options
context:
space:
mode:
authorTom Joseph <tomjoseph@in.ibm.com>2017-02-01 17:17:27 +0300
committerPatrick Williams <patrick@stwcx.xyz>2017-02-01 22:57:35 +0300
commitdcdc8ea6109f1ebcf8378b9ccf73b0672da5032c (patch)
treefec3b71739b734490c2122b0aafa28ce3851941d /meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb
parent821d074359f9259bf8f1b6cf34fc81368f79611a (diff)
downloadopenbmc-dcdc8ea6109f1ebcf8378b9ccf73b0672da5032c.tar.xz
Create symlink for IPMI Provider libraries
The IPMI provider libraries are installed into /usr/lib/ipmid-providers. If the provider library is applicable for host-ipmid channel then soft link is created to /usr/lib/host-ipmid. In this way the soft links are created for the provider library to the corresponding directory. Change-Id: I586bc830efd2b1d1ff1941181d1aa8d9a400f628 Signed-off-by: Tom Joseph <tomjoseph@in.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb
index d053bce666..e0fcb0f207 100644
--- a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb
@@ -4,6 +4,7 @@ PR = "r1"
inherit autotools pkgconfig
inherit obmc-phosphor-systemd
+inherit obmc-phosphor-ipmiprovider-symlink
require ${PN}.inc
@@ -21,5 +22,8 @@ SYSTEMD_SERVICE_${PN} += "obmc-read-eeprom@.service"
S = "${WORKDIR}/git"
+HOSTIPMI_PROVIDER_LIBRARY += "libstrgfnhandler.so"
+
+FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
-FILES_${PN}-dev_append = " ${libdir}/host-ipmid/lib*${SOLIBSDEV} ${libdir}/host-ipmid/*.la"
+FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"