summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-phosphor/mboxd
diff options
context:
space:
mode:
authorJosh D. King <jdking@us.ibm.com>2017-04-06 22:43:46 +0300
committerPatrick Williams <patrick@stwcx.xyz>2017-04-20 18:43:44 +0300
commitb9ee536d0aae31718054ddad187a93d761d9dea2 (patch)
tree95bd59def58214239025ac679138dfb9f82fc22c /meta-phosphor/common/recipes-phosphor/mboxd
parent360a31bed22a78cf09ed2df7f54dac7a700beacd (diff)
downloadopenbmc-b9ee536d0aae31718054ddad187a93d761d9dea2.tar.xz
Refactor action target names Power-on-off
The target change is: obmc-power-chassis-on -> obmc-chassis-poweron obmc-power-chassis-off -> obmc-chassis-poweroff Also updated phosphor-state-manager.bb to now have correct commit id. Change-Id: I15aae803e5f0d44d4e6a137278f93e91f848b2c0 Signed-off-by: Josh D. King <jdking@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/mboxd')
-rw-r--r--meta-phosphor/common/recipes-phosphor/mboxd/mboxd.bb2
-rw-r--r--meta-phosphor/common/recipes-phosphor/mboxd/mboxd/mboxd-reload@.service4
2 files changed, 3 insertions, 3 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/mboxd/mboxd.bb b/meta-phosphor/common/recipes-phosphor/mboxd/mboxd.bb
index e43a5b434e..2d52a2668e 100644
--- a/meta-phosphor/common/recipes-phosphor/mboxd/mboxd.bb
+++ b/meta-phosphor/common/recipes-phosphor/mboxd/mboxd.bb
@@ -36,7 +36,7 @@ do_install_append() {
}
TMPL = "mboxd-reload@.service"
-TGTFMT = "obmc-power-chassis-off@{0}.target"
+TGTFMT = "obmc-chassis-poweroff@{0}.target"
INSTFMT = "mboxd-reload@{0}.service"
FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}"
diff --git a/meta-phosphor/common/recipes-phosphor/mboxd/mboxd/mboxd-reload@.service b/meta-phosphor/common/recipes-phosphor/mboxd/mboxd/mboxd-reload@.service
index 9a8d8444b4..1b89de94f2 100644
--- a/meta-phosphor/common/recipes-phosphor/mboxd/mboxd/mboxd-reload@.service
+++ b/meta-phosphor/common/recipes-phosphor/mboxd/mboxd/mboxd-reload@.service
@@ -2,7 +2,7 @@
Description=Reload mboxd after power off
Wants=op-wait-power-off@%i.service
After=op-wait-power-off@%i.service
-Conflicts=obmc-power-chassis-on@%i.target
+Conflicts=obmc-chassis-poweron@%i.target
[Service]
Type=oneshot
@@ -10,4 +10,4 @@ RemainAfterExit=yes
ExecStart={sbindir}/mboxctl --reset
[Install]
-WantedBy=obmc-power-chassis-off@%i.target
+WantedBy=obmc-chassis-poweroff@%i.target