summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-phosphor/settings
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2017-12-14 22:31:55 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-01-30 23:37:44 +0300
commit0a8ea6354dd6b906f310316315fc49ace110a1ea (patch)
tree208ebd0de7c036c3b1d8b5cfe5037e27f4b60eaa /meta-phosphor/common/recipes-phosphor/settings
parent95eaf4978f6f92a848ba53accf02dcb52cee29b6 (diff)
downloadopenbmc-0a8ea6354dd6b906f310316315fc49ace110a1ea.tar.xz
Use variables for MRW XML filename and path
Create an mrw-xml bbclass that has variables for the MRW XML filename and path to it. Then, changes all users of the MRW XML to inherit that class and use those variables. The filename will default to ${MACHINE}.xml if it hasn't already been set to something else, such as in a .conf file. This is done so that the file can be something other than ${MACHINE}.xml. Change-Id: Ia7021e5a5d5e7946829e58688250aa64250cb00e Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/settings')
-rw-r--r--meta-phosphor/common/recipes-phosphor/settings/phosphor-settings-read-settings-mrw.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/settings/phosphor-settings-read-settings-mrw.bb b/meta-phosphor/common/recipes-phosphor/settings/phosphor-settings-read-settings-mrw.bb
index 7260434d3e..2080a3b6e7 100644
--- a/meta-phosphor/common/recipes-phosphor/settings/phosphor-settings-read-settings-mrw.bb
+++ b/meta-phosphor/common/recipes-phosphor/settings/phosphor-settings-read-settings-mrw.bb
@@ -7,6 +7,7 @@ PR = "r1"
inherit native
inherit phosphor-settings-manager
+inherit mrw-xml
inherit obmc-phosphor-license
@@ -26,7 +27,7 @@ do_install() {
# gen_settings.pl replaces any MRW variables with their value
${bindir}/perl-native/perl \
${bindir}/gen_settings.pl \
- -i ${datadir}/obmc-mrw/${MACHINE}.xml \
+ -i ${mrw_datadir}/${MRW_XML} \
-s ${DEST}/mrw-override-settings.yaml \
-o ${SETTINGS}/mrw-settings.override.yaml \
-f