summaryrefslogtreecommitdiff
path: root/meta-phosphor/common
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2016-07-16 19:15:30 +0300
committerGitHub <noreply@github.com>2016-07-16 19:15:30 +0300
commit5bc571e3988821f8ca2367cccfc7044bedd8f7f5 (patch)
tree37d5f75e05d39d850bf3ac0b97d7ce31025f6fcb /meta-phosphor/common
parent542d3a597cd2b6197885ff91eb19cfcddbc9e8fd (diff)
parent699b58aa7e16aca20dac22a35b25edc0650787ef (diff)
downloadopenbmc-5bc571e3988821f8ca2367cccfc7044bedd8f7f5.tar.xz
Merge pull request #468 from eddiejames/dev
python-ipy package
Diffstat (limited to 'meta-phosphor/common')
-rw-r--r--meta-phosphor/common/recipes-devtools/python/python-ipy_0.83.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-devtools/python/python-ipy_0.83.bb b/meta-phosphor/common/recipes-devtools/python/python-ipy_0.83.bb
new file mode 100644
index 0000000000..b2a9739972
--- /dev/null
+++ b/meta-phosphor/common/recipes-devtools/python/python-ipy_0.83.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Python module for handling IPv4 and IPv6 Addresses and Networks"
+DESCRIPTION = "IPy is a Python module for handling IPv4 and IPv6 Addresses and Networks \
+in a fashion similar to perl's Net::IP and friends. The IP class allows \
+a comfortable parsing and handling for most notations in use for IPv4 \
+and IPv6 Addresses and Networks."
+SECTION = "devel/python"
+HOMEPAGE = "https://github.com/haypo/python-ipy"
+DEPENDS = "python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=ebc0028ff5cdaf7796604875027dcd55"
+
+SRC_URI = "http://pypi.python.org/packages/source/I/IPy/IPy-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "7b8c6eb4111b15aea31b67108e769712"
+SRC_URI[sha256sum] = "61da5a532b159b387176f6eabf11946e7458b6df8fb8b91ff1d345ca7a6edab8"
+
+S = "${WORKDIR}/IPy-${PV}"
+
+inherit distutils
+
+# need to export these variables for python-config to work
+export BUILD_SYS
+export HOST_SYS
+export STAGING_INCDIR
+export STAGING_LIBDIR
+
+BBCLASSEXTEND = "native"
+
+do_install_append() {
+ install -d ${D}/${datadir}/doc/${BPN}-${PV}
+ install AUTHORS COPYING ChangeLog README ${D}/${datadir}/doc/${BPN}-${PV}
+}