summaryrefslogtreecommitdiff
path: root/meta-phosphor/common
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2016-07-14 00:56:34 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2016-07-28 21:35:37 +0300
commit8ffb402ac41c87b3b78c72d979168b0a2ada5fb5 (patch)
tree4e14a4815fe80a57ef202d7994f8e841686dbad7 /meta-phosphor/common
parent49a7698af82650ce5dd87bb4e52d20e0d209d022 (diff)
downloadopenbmc-8ffb402ac41c87b3b78c72d979168b0a2ada5fb5.tar.xz
classes-dbus: General refactoring
Take the more idiomatic approach of iterating on DBUS_PACKAGES to find files. Change-Id: I7656316b839f666bd1b25b757bef2c14a2cee326 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common')
-rw-r--r--meta-phosphor/common/recipes-phosphor/dbus-perms/dbus-perms.bb4
-rw-r--r--meta-phosphor/common/recipes-phosphor/dbus/obmc-mapper.bb2
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/obmc-phosphor-example-pydbus.bb4
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/obmc-phosphor-example-sdbus.bb4
4 files changed, 4 insertions, 10 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/dbus-perms/dbus-perms.bb b/meta-phosphor/common/recipes-phosphor/dbus-perms/dbus-perms.bb
index c7b7884266..c929d74b3b 100644
--- a/meta-phosphor/common/recipes-phosphor/dbus-perms/dbus-perms.bb
+++ b/meta-phosphor/common/recipes-phosphor/dbus-perms/dbus-perms.bb
@@ -7,6 +7,4 @@ inherit allarch
inherit obmc-phosphor-license
inherit obmc-phosphor-dbus-service
-DBUS_SERVICES += " \
- org.openbmc \
- "
+DBUS_SERVICE_${PN} += "org.openbmc"
diff --git a/meta-phosphor/common/recipes-phosphor/dbus/obmc-mapper.bb b/meta-phosphor/common/recipes-phosphor/dbus/obmc-mapper.bb
index 3c3208d2bc..12e54740a3 100644
--- a/meta-phosphor/common/recipes-phosphor/dbus/obmc-mapper.bb
+++ b/meta-phosphor/common/recipes-phosphor/dbus/obmc-mapper.bb
@@ -10,7 +10,7 @@ inherit obmc-phosphor-dbus-service
inherit obmc-phosphor-systemd
inherit setuptools
-DBUS_SERVICES += "org.openbmc.ObjectMapper"
+DBUS_SERVICE_${PN} += "org.openbmc.ObjectMapper"
RDEPENDS_${PN} += " \
python-xml \
python-dbus \
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/obmc-phosphor-example-pydbus.bb b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/obmc-phosphor-example-pydbus.bb
index 57e27cf781..7e3e90713c 100644
--- a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/obmc-phosphor-example-pydbus.bb
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/obmc-phosphor-example-pydbus.bb
@@ -2,9 +2,7 @@ SUMMARY = "Phosphor OpenBMC BSP Example Application"
DESCRIPTION = "Phosphor OpenBMC QEMU BSP example implementation."
PR = "r1"
-DBUS_SERVICES = " \
- org.openbmc.examples.PythonService \
- "
+DBUS_SERVICE_${PN} += "org.openbmc.examples.PythonService"
inherit obmc-phosphor-pydbus-service
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/obmc-phosphor-example-sdbus.bb b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/obmc-phosphor-example-sdbus.bb
index 9a3018d373..541aa79436 100644
--- a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/obmc-phosphor-example-sdbus.bb
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/obmc-phosphor-example-sdbus.bb
@@ -2,9 +2,7 @@ SUMMARY = "Phosphor OpenBMC BSP Example Application"
DESCRIPTION = "Phosphor OpenBMC QEMU BSP example implementation."
PR = "r1"
-DBUS_SERVICES = " \
- org.openbmc.examples.SDBusService \
- "
+DBUS_SERVICE_${PN} += "org.openbmc.examples.SDBusService"
S = "${WORKDIR}"
SRC_URI += "file://Makefile \