summaryrefslogtreecommitdiff
path: root/meta-phosphor/common
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2017-04-29 00:05:39 +0300
committerPatrick Williams <patrick@stwcx.xyz>2017-05-19 18:22:26 +0300
commitf20b3aa32c07af4fdc7db6935444aa101d3b383a (patch)
treecd32cc1fff4d07cbe9c9b8800c10930f6fd119cd /meta-phosphor/common
parentbea7ab535e8ae6fc1ff2b730f254532dc1667139 (diff)
downloadopenbmc-f20b3aa32c07af4fdc7db6935444aa101d3b383a.tar.xz
openpower-pnor-code-mgmt: Initial recipe
Create recipe for the openpower-pnor-code-mgmt repo. Move the pnor-specific service files from the phosphor layer to the open-power one. Add the new openpower-software-manager to packagegroups. Change-Id: Iab47b82e6872f7f92aed6260c51eaf0acf744aeb Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common')
-rw-r--r--meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios.bb5
-rw-r--r--meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios/obmc-flash-bios-squashfsmount@.service14
-rw-r--r--meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios/obmc-flash-bios-ubiattach.service8
-rw-r--r--meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios/obmc-flash-bios-ubimount@.service11
4 files changed, 0 insertions, 38 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios.bb b/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios.bb
index 2137de4141..c425027bff 100644
--- a/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios.bb
+++ b/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios.bb
@@ -7,11 +7,6 @@ PR = "r1"
inherit skeleton-gdbus
inherit obmc-phosphor-dbus-service
-RDEPENDS_${PN} += "mtd-utils-ubifs"
-
SKELETON_DIR = "flashbios"
DBUS_SERVICE_${PN} += "org.openbmc.control.Flash.service"
SYSTEMD_SERVICE_${PN} += "obmc-flash-init.service"
-SYSTEMD_SERVICE_${PN} += "obmc-flash-bios-ubiattach.service"
-SYSTEMD_SERVICE_${PN} += "obmc-flash-bios-ubimount@.service"
-SYSTEMD_SERVICE_${PN} += "obmc-flash-bios-squashfsmount@.service"
diff --git a/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios/obmc-flash-bios-squashfsmount@.service b/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios/obmc-flash-bios-squashfsmount@.service
deleted file mode 100644
index 1bf15bfd45..0000000000
--- a/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios/obmc-flash-bios-squashfsmount@.service
+++ /dev/null
@@ -1,14 +0,0 @@
-[Unit]
-Description=Mount SquashFS image pnor-ro-%I
-Requires=obmc-flash-bios-ubiattach.service
-After=obmc-flash-bios-ubiattach.service
-
-[Service]
-Type=oneshot
-RemainAfterExit=yes
-ExecStart=/bin/sh -c '{sbindir}/ubimkvol /dev/ubi0 -N pnor-ro-%i -s 32MiB --type=static; \
- mkdir /media/pnor-ro-%i; \
- volumeid%i=`ubinfo -d 0 -N pnor-ro-%i | grep "Volume ID" | sed -e "s|Volume ID:||" -e "s/^ *//" | grep -o "^\S*"`; \
- ubiblock --create /dev/ubi0_$volumeid%i; \
- ubiupdatevol /dev/ubi0_$volumeid%i /tmp/images/%i/pnor.xz.squashfs; \
- mount -t squashfs -o ro /dev/ubiblock0_$volumeid%i /media/pnor-ro-%i'
diff --git a/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios/obmc-flash-bios-ubiattach.service b/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios/obmc-flash-bios-ubiattach.service
deleted file mode 100644
index 90013ff1e5..0000000000
--- a/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios/obmc-flash-bios-ubiattach.service
+++ /dev/null
@@ -1,8 +0,0 @@
-[Unit]
-Description=Attach the PNOR mtd device to UBI
-
-[Service]
-Type=oneshot
-RemainAfterExit=yes
-ExecStart=/bin/sh -c 'grep pnor /proc/mtd |cut -c 4 |xargs {sbindir}/ubiattach /dev/ubi_ctrl -m'
-ExecStop=/bin/sh -c 'grep pnor /proc/mtd |cut -c 4 |xargs {sbindir}/ubidetach /dev/ubi_ctrl -m'
diff --git a/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios/obmc-flash-bios-ubimount@.service b/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios/obmc-flash-bios-ubimount@.service
deleted file mode 100644
index 5abab7f211..0000000000
--- a/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios/obmc-flash-bios-ubimount@.service
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=Mount UBIFS volume pnor-rw-%I
-Requires=obmc-flash-bios-ubiattach.service
-After=obmc-flash-bios-ubiattach.service
-
-[Service]
-Type=oneshot
-RemainAfterExit=yes
-ExecStart=/bin/sh -c '{sbindir}/ubimkvol /dev/ubi0 -N pnor-rw-%i -s 1MiB; \
- mkdir /media/pnor-rw-%i; \
- mount -t ubifs ubi0:pnor-rw-%i /media/pnor-rw-%i'