summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-core/systemd/systemd_%.bbappend
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-31 13:25:51 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-06 14:44:12 +0300
commitff075f6ee795a590b244d70a90cc312ba1f2d83d (patch)
treea617790bdbfdeef960665ba0242e1f0c93e5301a /meta-phosphor/recipes-core/systemd/systemd_%.bbappend
parent3e4da38c127bb7e7641adc2fc41f4c33744cb918 (diff)
downloadopenbmc-ff075f6ee795a590b244d70a90cc312ba1f2d83d.tar.xz
meta-phosphor: Move layer content from common/
Adopt a more conventional directory hierarchy. meta-phosphor is still a _long_ way from suitable for hosting on yoctoproject.org but things like this don't help. (From meta-phosphor rev: 471cfcefa74b8c7ceb704cb670e6d915cf27c63b) Change-Id: I3f106b2f6cdc6cec734be28a6090800546f362eb Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-core/systemd/systemd_%.bbappend')
-rw-r--r--meta-phosphor/recipes-core/systemd/systemd_%.bbappend22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-core/systemd/systemd_%.bbappend b/meta-phosphor/recipes-core/systemd/systemd_%.bbappend
new file mode 100644
index 0000000000..b403069a58
--- /dev/null
+++ b/meta-phosphor/recipes-core/systemd/systemd_%.bbappend
@@ -0,0 +1,22 @@
+FILES_${PN}-catalog-extralocales = \
+ "${exec_prefix}/lib/systemd/catalog/*.*.catalog"
+PACKAGES =+ "${PN}-catalog-extralocales"
+PACKAGECONFIG_append = " networkd coredump"
+PACKAGECONFIG_remove = "machined hibernate ldconfig binfmt backlight localed \
+ quotacheck kdbus ima smack polkit logind bootchart utmp \
+ manpages"
+FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
+SRC_URI += "file://default.network"
+SRC_URI += "file://0001-sd-bus-Don-t-automatically-add-ObjectManager.patch"
+SRC_URI += "file://0003-basic-Factor-out-string-checking-from-name_to_prefix.patch"
+SRC_URI += "file://0004-basic-Use-path-escaping-when-mangling-path-instances.patch"
+#TODO upstream the below patch via below issue
+#https://github.com/openbmc/openbmc/issues/2016
+SRC_URI += "file://0005-dont-return-error-if-unable-to-create-network-namespace.patch"
+
+RRECOMMENDS_${PN} += "obmc-targets"
+FILES_${PN} += "${systemd_unitdir}/network/default.network"
+
+do_install_append() {
+ install -m 644 ${WORKDIR}/default.network ${D}${systemd_unitdir}/network/
+}