summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-core
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2022-11-18 21:47:02 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-11-19 02:05:48 +0300
commitbcd2905075841c88ac2e345b92551dc82490accb (patch)
treecea77b4adf3b730f957678b2cca1e2e5eda58beb /meta-phosphor/recipes-core
parentc4d1d481bdc53c7bb8b995b7a18eaa82c27fc171 (diff)
downloadopenbmc-bcd2905075841c88ac2e345b92551dc82490accb.tar.xz
meta-phosphor: systemd: remove udev from USERADD_PACKAGES
The latest Yocto adds udev to the USERADD_PACKAGES set, which causes it to have a RDEPENDS on "shadow". We explicitly remove shadow from our initramfs due to not wanting the size of it and all the corresponding PAM modules. Having it set breaks p10bmc where we pull a udev-requiring script into the initramfs. The only reason udev is currently in the USERADD_PACKAGES is due to a need for a specific udev rule related to graphics adding a `render` group. Since this isn't applicable to the BMC, I'm removing udev from the USERADD_PACKAGES for us. Change-Id: I9b92dbefc691f91c179a0bfcb5bd228bb27b738a Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Diffstat (limited to 'meta-phosphor/recipes-core')
-rw-r--r--meta-phosphor/recipes-core/systemd/systemd_%.bbappend8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-core/systemd/systemd_%.bbappend b/meta-phosphor/recipes-core/systemd/systemd_%.bbappend
index b09f2e23f8..3663434176 100644
--- a/meta-phosphor/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-phosphor/recipes-core/systemd/systemd_%.bbappend
@@ -26,6 +26,14 @@ FILES:${PN}-catalog-extralocales = "\
${exec_prefix}/lib/systemd/catalog/*.*.catalog \
"
+# udev is added to the USERADD_PACKAGES due to some 'render' group
+# being necessary to create for /dev/dri handling, which we don't
+# have to worry about. A side-effect of this is udev would RDEPEND on
+# 'shadow' which prevents us from putting it into the initramfs. We
+# have plenty of other stuff that RDEPENDS on 'shadow' so, remove udev
+# from USERADD_PACKAGES to get around that.
+USERADD_PACKAGES:remove = "udev"
+
ALTERNATIVE_LINK_NAME[init] = "${base_sbindir}/init"
ALTERNATIVE_PRIORITY[init] ?= "300"