summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-extended/pam/libpam_%.bbappend
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2018-10-16 19:32:13 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-11-01 18:13:10 +0300
commit31ab8e7adb8b87070428c32d39f9296cf3506932 (patch)
tree2540bce6ef24828db7c2cb59218b548a6c2f3633 /meta-phosphor/recipes-extended/pam/libpam_%.bbappend
parent46b48ef7df11bde2d5231468a0dff0611b949e99 (diff)
downloadopenbmc-31ab8e7adb8b87070428c32d39f9296cf3506932.tar.xz
Remove pam_systemd.so from common-session pam conf
The libpam recipe adds pam_systemd.so into /etc/pam.d/common-session if it detects systemd is enabled. However, systemd only installs pam_systemd.so if the systemd-logind package is installed, which openBMC doesn't want. So now when common-session is used by a pam module, there are errors in the journal saying it can't find pam_systemd.so. To fix this, remove the pam_systemd.so line ourselves. Tested: Verified that the line containing pam_systemd.so is no longer in the common-session file, and that there are no errors in the journal when logging in via REST. (From meta-phosphor rev: 3457266de2ac93bb453a094a45d14e4ea082e955) Change-Id: Iae091e2df1c543b5f679a55863329b4dd4d3b5c8 Signed-off-by: Matt Spinler <spinler@us.ibm.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-extended/pam/libpam_%.bbappend')
-rw-r--r--meta-phosphor/recipes-extended/pam/libpam_%.bbappend7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-extended/pam/libpam_%.bbappend b/meta-phosphor/recipes-extended/pam/libpam_%.bbappend
new file mode 100644
index 0000000000..714496a947
--- /dev/null
+++ b/meta-phosphor/recipes-extended/pam/libpam_%.bbappend
@@ -0,0 +1,7 @@
+do_install_append() {
+ # The libpam recipe will always add a pam_systemd.so line to
+ # common-session if systemd is enabled; however systemd only
+ # builds pam_systemd.so if logind is enabled, and we disable
+ # that package. So, remove the pam_systemd.so line here.
+ sed -i '/pam_systemd.so/d' ${D}${sysconfdir}/pam.d/common-session
+}