summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-extended
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-31 13:25:51 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-06 14:44:12 +0300
commitff075f6ee795a590b244d70a90cc312ba1f2d83d (patch)
treea617790bdbfdeef960665ba0242e1f0c93e5301a /meta-phosphor/recipes-extended
parent3e4da38c127bb7e7641adc2fc41f4c33744cb918 (diff)
downloadopenbmc-ff075f6ee795a590b244d70a90cc312ba1f2d83d.tar.xz
meta-phosphor: Move layer content from common/
Adopt a more conventional directory hierarchy. meta-phosphor is still a _long_ way from suitable for hosting on yoctoproject.org but things like this don't help. (From meta-phosphor rev: 471cfcefa74b8c7ceb704cb670e6d915cf27c63b) Change-Id: I3f106b2f6cdc6cec734be28a6090800546f362eb Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-extended')
-rw-r--r--meta-phosphor/recipes-extended/gpioplus/gpioplus_git.bb23
-rw-r--r--meta-phosphor/recipes-extended/sdbusplus/sdbusplus.bb55
-rw-r--r--meta-phosphor/recipes-extended/sdeventplus/sdeventplus_git.bb24
3 files changed, 102 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-extended/gpioplus/gpioplus_git.bb b/meta-phosphor/recipes-extended/gpioplus/gpioplus_git.bb
new file mode 100644
index 0000000000..6fbc03cfa2
--- /dev/null
+++ b/meta-phosphor/recipes-extended/gpioplus/gpioplus_git.bb
@@ -0,0 +1,23 @@
+SUMMARY = "C++ bindings for linux gpio APIs"
+DESCRIPTION = "C++ bindings for linux gpio APIs."
+HOMEPAGE = "http://github.com/openbmc/gpioplus"
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+inherit autotools pkgconfig
+
+DEPENDS += " \
+ autoconf-archive-native \
+ "
+
+EXTRA_OECONF_append += " \
+ --disable-examples \
+ --disable-tests \
+ "
+
+SRC_URI += "git://github.com/openbmc/gpioplus"
+SRCREV = "68cce0fad1549f5144160182edd24bcdb83df6e0"
+
+S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-extended/sdbusplus/sdbusplus.bb b/meta-phosphor/recipes-extended/sdbusplus/sdbusplus.bb
new file mode 100644
index 0000000000..8a2d5ed2cf
--- /dev/null
+++ b/meta-phosphor/recipes-extended/sdbusplus/sdbusplus.bb
@@ -0,0 +1,55 @@
+SUMMARY = "C++ bindings for systemd dbus APIs"
+DESCRIPTION = "C++ bindings for systemd dbus APIs."
+HOMEPAGE = "http://github.com/openbmc/sdbusplus"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-python-autotools
+
+DEPENDS += " \
+ autoconf-archive-native \
+ python-inflection-native \
+ python-mako-native \
+ python-pyyaml-native \
+ "
+RDEPENDS_sdbus++ += " \
+ python-inflection \
+ python-mako \
+ python-pyyaml \
+ "
+
+# sdbus++ has a handful of runtime dependencies on other python packages.
+# Bitbake doesn't do anything with RDEPENDS in native context because
+# native context doesn't have packages.
+#
+# While technically sdbus++ doesn't require its runtime dependencies to be
+# installed to build, work around the above native context behavior
+# by adding a build dependency so that clients don't have to DEPEND
+# on sdbus++ runtime dependencies manually.
+
+DEPENDS_append_class-native = " \
+ python-inflection-native \
+ python-mako-native \
+ python-pyyaml-native \
+ "
+
+SRC_URI += "git://github.com/openbmc/sdbusplus"
+SRCREV = "e0d6965e73f1f648ed02e483277f81a328ecb6df"
+
+PACKAGECONFIG ??= "libsdbusplus transaction"
+PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd"
+PACKAGECONFIG[transaction] = "--enable-transaction,--disable-transaction"
+
+S = "${WORKDIR}/git"
+
+PROVIDES_prepend = "sdbus++ "
+PACKAGE_BEFORE_PN = "sdbus++"
+FILES_sdbus++_append = " ${bindir}/sdbus++"
+PYTHON_AUTOTOOLS_PACKAGE = "sdbus++"
+
+PACKAGECONFIG_remove_class-native = "libsdbusplus"
+PACKAGECONFIG_remove_class-nativesdk = "libsdbusplus"
+
+BBCLASSEXTEND += "native nativesdk"
diff --git a/meta-phosphor/recipes-extended/sdeventplus/sdeventplus_git.bb b/meta-phosphor/recipes-extended/sdeventplus/sdeventplus_git.bb
new file mode 100644
index 0000000000..ef36051412
--- /dev/null
+++ b/meta-phosphor/recipes-extended/sdeventplus/sdeventplus_git.bb
@@ -0,0 +1,24 @@
+SUMMARY = "C++ bindings for systemd event APIs"
+DESCRIPTION = "C++ bindings for systemd event APIs."
+HOMEPAGE = "http://github.com/openbmc/sdeventplus"
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+inherit autotools pkgconfig
+
+DEPENDS += " \
+ autoconf-archive-native \
+ systemd \
+ "
+
+EXTRA_OECONF_append += " \
+ --disable-examples \
+ --disable-tests \
+ "
+
+SRC_URI += "git://github.com/openbmc/sdeventplus"
+SRCREV = "d38b8ffc4ee5324cf7865f31b2492a5f95e928eb"
+
+S = "${WORKDIR}/git"