summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-kernel/linux
diff options
context:
space:
mode:
authorRashmica Gupta <rashmica@linux.ibm.com>2023-02-01 07:26:58 +0300
committerAndrew Jeffery <andrew@aj.id.au>2023-06-14 02:50:06 +0300
commitddaca3c8875179e98e0dcb72632dcc185e8c52e5 (patch)
tree4c8d623ea9fc4762f9a38a47c6d1fc8bf03208d7 /meta-phosphor/recipes-kernel/linux
parent440d4d273c73847919ce098141949dbc785c3046 (diff)
downloadopenbmc-ddaca3c8875179e98e0dcb72632dcc185e8c52e5.tar.xz
meta-ibm: p10bmc: add a MCTP DISTRO_FEATURES switch
The switch enables AF_MCTP and adds the `mctp` tool and `mctpd` so we can setup and manage an in-kernel MCTP network. Enable it for p10bmc and also add CONFIG_TUN so we can use a tun device to transport packets between the kernel and the astlpc interface implemented in libmctp. Change-Id: I21d0af9e751f91975c760b4b4708b3b401b95417 Signed-off-by: Rashmica Gupta <rashmica@linux.ibm.com>
Diffstat (limited to 'meta-phosphor/recipes-kernel/linux')
-rw-r--r--meta-phosphor/recipes-kernel/linux/linux-%.bbappend5
-rw-r--r--meta-phosphor/recipes-kernel/linux/mctp/mctp.cfg3
-rw-r--r--meta-phosphor/recipes-kernel/linux/mctp/mctp.scc3
3 files changed, 10 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-kernel/linux/linux-%.bbappend b/meta-phosphor/recipes-kernel/linux/linux-%.bbappend
index 32876c413a..db375e4e85 100644
--- a/meta-phosphor/recipes-kernel/linux/linux-%.bbappend
+++ b/meta-phosphor/recipes-kernel/linux/linux-%.bbappend
@@ -1,2 +1,5 @@
FILESEXTRAPATHS:prepend := "${THISDIR}:"
-SRC_URI:append = " file://systemd-bootchart.cfg"
+SRC_URI:append = " \
+ file://systemd-bootchart.cfg \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'mctp', 'file://mctp/mctp.scc file://mctp/mctp.cfg', '', d)} \
+ "
diff --git a/meta-phosphor/recipes-kernel/linux/mctp/mctp.cfg b/meta-phosphor/recipes-kernel/linux/mctp/mctp.cfg
new file mode 100644
index 0000000000..26f3c4157e
--- /dev/null
+++ b/meta-phosphor/recipes-kernel/linux/mctp/mctp.cfg
@@ -0,0 +1,3 @@
+CONFIG_MCTP=y
+CONFIG_MCTP_SERIAL=y
+CONFIG_MCTP_TRANSPORT_I2C=y
diff --git a/meta-phosphor/recipes-kernel/linux/mctp/mctp.scc b/meta-phosphor/recipes-kernel/linux/mctp/mctp.scc
new file mode 100644
index 0000000000..d1fe804345
--- /dev/null
+++ b/meta-phosphor/recipes-kernel/linux/mctp/mctp.scc
@@ -0,0 +1,3 @@
+define KFEATURE_DESCRIPTION "Enable MCTP"
+
+kconf non-hardware mctp.cfg