summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/bios
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2022-09-19 19:13:20 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-09-20 17:02:39 +0300
commit9936f86df6fc55be042cec5eb15f6e19a9e7c890 (patch)
tree251861f6bba6451ddfe328558097f6abf438d8d6 /meta-phosphor/recipes-phosphor/bios
parentbb8f0657781d78264d08d324853f94bd1abc8efa (diff)
downloadopenbmc-9936f86df6fc55be042cec5eb15f6e19a9e7c890.tar.xz
Run oe-stylize on our files
In all of our recipes, we should be following yoctos lead on formatting, order, and other things, for consistency in our meta layers. This commit runs oe-stylize.py on all of our files. The types of changes being made can be seen in the commit, but amount to: 1. Setting an explicit key ordering 2. Sectioning the files appropriately 3. Applying rules checking to our files At some point in the near future, we would turn this on as part of repotest, but some minor changes need to be upstreamed to meta-oe (WIP) to make that happen. Looking for input on whether this is something we'd like to do, and whether the diffs below look reasonable to folks. Signed-off-by: Ed Tanous <edtanous@google.com> Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
Diffstat (limited to 'meta-phosphor/recipes-phosphor/bios')
-rw-r--r--meta-phosphor/recipes-phosphor/bios/biosconfig-manager_git.bb27
1 files changed, 11 insertions, 16 deletions
diff --git a/meta-phosphor/recipes-phosphor/bios/biosconfig-manager_git.bb b/meta-phosphor/recipes-phosphor/bios/biosconfig-manager_git.bb
index af8c6091cd..683e7e3f20 100644
--- a/meta-phosphor/recipes-phosphor/bios/biosconfig-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/bios/biosconfig-manager_git.bb
@@ -1,26 +1,11 @@
-HOMEPAGE = "https://github.com/openbmc/bios-settings-mgr"
-
SUMMARY = "Remote BIOS Configuration via BMC"
-
DESCRIPTION = "Provides ability for the user to view and modify the BIOS setup \
configuration parameters remotely via BMC at any Host state. \
Modifications to the parameters take place upon the next system \
reboot or immediate based on the host firmware."
-
-PR = "r1"
-PV = "1.0+git${SRCPV}"
+HOMEPAGE = "https://github.com/openbmc/bios-settings-mgr"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=bcd9ada3a943f58551867d72893cc9ab"
-
-SRC_URI = "git://github.com/openbmc/bios-settings-mgr;branch=master;protocol=https"
-SRCREV = "36cd3238d75c5f3479a944a2f1a9a3abc316120a"
-
-inherit meson pkgconfig systemd
-
-S = "${WORKDIR}/git"
-SYSTEMD_SERVICE:${PN} = "xyz.openbmc_project.biosconfig_manager.service \
- xyz.openbmc_project.biosconfig_password.service"
-
DEPENDS = " boost \
openssl \
phosphor-dbus-interfaces \
@@ -28,4 +13,14 @@ DEPENDS = " boost \
sdbusplus \
systemd \
nlohmann-json "
+SRCREV = "36cd3238d75c5f3479a944a2f1a9a3abc316120a"
+PV = "1.0+git${SRCPV}"
+PR = "r1"
+SRC_URI = "git://github.com/openbmc/bios-settings-mgr;branch=master;protocol=https"
+
+S = "${WORKDIR}/git"
+SYSTEMD_SERVICE:${PN} = "xyz.openbmc_project.biosconfig_manager.service \
+ xyz.openbmc_project.biosconfig_password.service"
+
+inherit meson pkgconfig systemd