summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/certificate
diff options
context:
space:
mode:
authorAnton D. Kachalov <gmouse@google.com>2021-04-21 20:23:55 +0300
committerAnton D. Kachalov <gmouse@google.com>2021-10-03 18:40:03 +0300
commit31ecbfbce51fd02e6ae1fd31cdf04e7d0bebee0d (patch)
tree6ce001f59075dad9a906e9583067b990fbdf11b8 /meta-phosphor/recipes-phosphor/certificate
parent609d48731fd3758910ed5a68d5ce1d6e80c2dfd3 (diff)
downloadopenbmc-31ecbfbce51fd02e6ae1fd31cdf04e7d0bebee0d.tar.xz
certificate-manager: ship nslcd config from user-manager repo
This change required as a part of privilege separation work: https://github.com/openbmc/openbmc/issues/3383 This change should be merged after individual repo change: https://gerrit.openbmc-project.xyz/c/openbmc/phosphor-user-manager/+/42633 Signed-off-by: Anton D. Kachalov <gmouse@google.com> Change-Id: I3d68a3cb27f822b05027ef07a89e6c65f6859178
Diffstat (limited to 'meta-phosphor/recipes-phosphor/certificate')
-rw-r--r--meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-cert-config.bb30
-rw-r--r--meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-cert-config/env9
2 files changed, 0 insertions, 39 deletions
diff --git a/meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-cert-config.bb b/meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-cert-config.bb
deleted file mode 100644
index 7b1e264120..0000000000
--- a/meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-cert-config.bb
+++ /dev/null
@@ -1,30 +0,0 @@
-SUMMARY = "Phosphor certificate manager configuration for a nslcd certificate"
-
-PR = "r1"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-RDEPENDS:${PN} = "phosphor-certificate-manager"
-
-inherit allarch
-
-SRC_URI = "file://env"
-
-FILES:${PN} = "${datadir}"
-
-do_install() {
- install -D ${WORKDIR}/env ${D}/${datadir}/phosphor-certificate-manager/nslcd
-}
-
-pkg_postinst:${PN}() {
- LINK="$D$systemd_system_unitdir/multi-user.target.wants/phosphor-certificate-manager@nslcd.service"
- TARGET="../phosphor-certificate-manager@.service"
- mkdir -p $D$systemd_system_unitdir/multi-user.target.wants
- ln -s $TARGET $LINK
-}
-
-pkg_prerm:${PN}() {
- LINK="$D$systemd_system_unitdir/multi-user.target.wants/phosphor-certificate-manager@nslcd.service"
- rm $LINK
-}
diff --git a/meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-cert-config/env b/meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-cert-config/env
deleted file mode 100644
index 8ac1bf77ef..0000000000
--- a/meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-cert-config/env
+++ /dev/null
@@ -1,9 +0,0 @@
-#REST URI endpoint
-#example: /xyz/openbmc_project/certs/client/ldap
-ENDPOINT=ldap
-
-#Path for the certificate file
-CERTPATH=/etc/nslcd/certs/cert.pem
-
-#Type of the service client/server
-TYPE=client