summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/chassis/phosphor-skeleton-control-power_git.bb
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2024-03-09 06:44:55 +0300
committerPatrick Williams <patrick@stwcx.xyz>2024-03-11 18:18:37 +0300
commitb81c1fb76edaf43e864854cb668fd5e7b1f88816 (patch)
tree4b0790b60e411c86c4e21fc23de34c6b22030488 /meta-phosphor/recipes-phosphor/chassis/phosphor-skeleton-control-power_git.bb
parent828c130f59bb3e2cb5cdfd47ac424aa4407bb0b3 (diff)
downloadopenbmc-b81c1fb76edaf43e864854cb668fd5e7b1f88816.tar.xz
meta-phosphor: add vardeps for HOST and CHASSIS instances
If a system were to change the OBMC_HOST_INSTANCES or OBMC_CHASSIS_INSTANCES, many packages (incorrectly) do not get rebuilt. This is because the variables are evaluated within Python contexts and are not manually specified in the `vardeps`. Add as necessary. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I84651a1a85a5c977be674d8b26b6e43e5ab46850
Diffstat (limited to 'meta-phosphor/recipes-phosphor/chassis/phosphor-skeleton-control-power_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/chassis/phosphor-skeleton-control-power_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/chassis/phosphor-skeleton-control-power_git.bb b/meta-phosphor/recipes-phosphor/chassis/phosphor-skeleton-control-power_git.bb
index 1912c571f7..e691623993 100644
--- a/meta-phosphor/recipes-phosphor/chassis/phosphor-skeleton-control-power_git.bb
+++ b/meta-phosphor/recipes-phosphor/chassis/phosphor-skeleton-control-power_git.bb
@@ -16,6 +16,7 @@ OBMC_CONTROL_INST = "org.openbmc.control.Power@{0}.service"
OBMC_CONTROL_SVC = "org.openbmc.control.Power@.service"
OBMC_CONTROL_FMT = "../${OBMC_CONTROL_SVC}:multi-user.target.wants/${OBMC_CONTROL_INST}"
SYSTEMD_LINK:${PN} += "${@compose_list(d, 'OBMC_CONTROL_FMT', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_LINK[vardeps] += "OBMC_CHASSIS_INSTANCES"
SYSTEMD_SERVICE:${PN} += " \
phosphor-wait-power-on@.service \