summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/chassis
diff options
context:
space:
mode:
authorNaveen Moses <naveen.mosess@hcl.com>2022-07-19 22:06:02 +0300
committerNaveen Moses <naveen.mosess@hcl.com>2022-10-04 18:37:43 +0300
commit1ede6c115a9faa77f420355ad080d221f3facd16 (patch)
treedcddfd1b7412c4078481dbca89ad21d434cf9e4b /meta-phosphor/recipes-phosphor/chassis
parentb7590f68b6e3865b8ccbf005361569179c7ae0dd (diff)
downloadopenbmc-1ede6c115a9faa77f420355ad080d221f3facd16.tar.xz
meta-facebook : Add phosphor-buttons gpio config YV2
This change adds phosphor-buttons gpio configs for the following : 1. Power button 2. Reset button 3. Host selector 4. Debug host selector button 5. serial uart mux To keep the install method common for copying gpio_defs.json file in supported platforms the install method is moved to obmc-phosphor-buttons_git.bb file. Signed-off-by: Naveen Moses <naveen.mosess@hcl.com> Change-Id: I91a106fdc5ac9aa83eec63cbd41a9615b380c37d
Diffstat (limited to 'meta-phosphor/recipes-phosphor/chassis')
-rw-r--r--meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb b/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb
index e5f72ac842..464139e990 100644
--- a/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb
+++ b/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb
@@ -32,3 +32,11 @@ ALLOW_EMPTY:${PN} = "1"
BUTTON_PACKAGES = "${PN}-signals ${PN}-handler"
PACKAGE_BEFORE_PN += "${BUTTON_PACKAGES}"
+
+do_install:append() {
+ if [ -e "${WORKDIR}/gpio_defs.json" ]; then
+ install -m 0755 -d ${D}/etc/default/obmc/gpio
+ install -m 0644 -D ${WORKDIR}/gpio_defs.json \
+ ${D}/etc/default/obmc/gpio
+ fi
+} \ No newline at end of file