summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/chassis
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2022-10-12 22:49:13 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-10-13 13:53:10 +0300
commit7a6ab4208d15ce91396f8f57c776de1bca1017c4 (patch)
treee8f8611fee111ee475d06dab23d9de790ef0715e /meta-phosphor/recipes-phosphor/chassis
parent9a424755c255258c48c8bb97cdc0eb5eb9a6c6df (diff)
downloadopenbmc-7a6ab4208d15ce91396f8f57c776de1bca1017c4.tar.xz
meta-phosphor: remove unused skeleton recipes
There are a few recipes using Python2 code and having no references inside the repository. Deleting them since there are no users and it is pretty unlikely that anyone outside is using them. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I89570580a469730f16870c54f850f8723cad55cf
Diffstat (limited to 'meta-phosphor/recipes-phosphor/chassis')
-rw-r--r--meta-phosphor/recipes-phosphor/chassis/obmc-control-chassis/org.openbmc.control.Chassis@.service14
-rw-r--r--meta-phosphor/recipes-phosphor/chassis/obmc-control-chassis_git.bb19
2 files changed, 0 insertions, 33 deletions
diff --git a/meta-phosphor/recipes-phosphor/chassis/obmc-control-chassis/org.openbmc.control.Chassis@.service b/meta-phosphor/recipes-phosphor/chassis/obmc-control-chassis/org.openbmc.control.Chassis@.service
deleted file mode 100644
index cfda54a026..0000000000
--- a/meta-phosphor/recipes-phosphor/chassis/obmc-control-chassis/org.openbmc.control.Chassis@.service
+++ /dev/null
@@ -1,14 +0,0 @@
-[Unit]
-Description=Phosphor Chassis%i Control
-
-[Service]
-Restart=always
-ExecStart=/usr/bin/env chassis_control.py
-SyslogIdentifier=chassis_control.py
-Type=dbus
-BusName={BUSNAME}
-Environment="PYTHONUNBUFFERED=1"
-TimeoutStartSec=180s
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-phosphor/recipes-phosphor/chassis/obmc-control-chassis_git.bb b/meta-phosphor/recipes-phosphor/chassis/obmc-control-chassis_git.bb
deleted file mode 100644
index 1f98bc0548..0000000000
--- a/meta-phosphor/recipes-phosphor/chassis/obmc-control-chassis_git.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-SUMMARY = "OpenBMC org.openbmc.control.Chassis example implementation"
-DESCRIPTION = "An example implementation of the org.openbmc.control.Chassis DBUS API."
-PV = "1.0+git${SRCPV}"
-PR = "r1"
-
-SKELETON_DIR = "pychassisctl"
-
-inherit skeleton-python
-inherit obmc-phosphor-dbus-service
-
-RDEPENDS:${PN} += "\
- python-dbus \
- python-pygobject \
- python-netclient \
- pyphosphor-dbus \
- "
-
-FMT = "org.openbmc.control.Chassis@{0}.service"
-DBUS_SERVICE:${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"