summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-23 05:52:33 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-11-01 05:55:16 +0300
commit711ae0ebce1f127412be3cfd232ee1762bbd0cc0 (patch)
tree07898768da2257b874df9a16a62448d5ab7349bd /meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb
parentac3fc9491a00edc39f06c09c719223c6cceb8911 (diff)
downloadopenbmc-711ae0ebce1f127412be3cfd232ee1762bbd0cc0.tar.xz
phosphor-mapper: remove deprecated path whitelist
The c++ mapper implements dbus service whitelists in place of path based whitelists. Drop support for path whitelists. (From meta-phosphor rev: d4816d2868a251a0a4048219de0e9411eed8c853) Change-Id: I7ca6c4b01e644b8008169cc63c9259801c42f27f Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb9
1 files changed, 0 insertions, 9 deletions
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb
index 7b793ec9b2..ee5fa0e587 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb
@@ -53,12 +53,6 @@ FILES_${PN}_remove = "${libdir}/lib*.so.* ${libdir}/*"
# from the native sysroot /usr/share/phosphor-mapper filesystem.
python do_emit_env() {
path = d.getVar('STAGING_DIR_NATIVE', True) + \
- d.getVar('namespace_dir', True)
- paths = []
- for p in os.listdir(path):
- paths.append(os.sep.join(p.split('-')))
-
- path = d.getVar('STAGING_DIR_NATIVE', True) + \
d.getVar('service_dir', True)
services = []
for s in os.listdir(path):
@@ -85,8 +79,6 @@ python do_emit_env() {
if not os.path.exists(parent):
os.makedirs(parent)
with open(path, 'w+') as fd:
- fd.write('MAPPER_NAMESPACES="{}"'.format(' '.join(paths)))
- fd.write('\n')
fd.write('MAPPER_SERVICES="{}"'.format(' '.join(services)))
fd.write('\n')
fd.write('MAPPER_INTERFACES="{}"'.format(' '.join(interfaces)))
@@ -96,4 +88,3 @@ python do_emit_env() {
}
do_install[postfuncs] += "do_emit_env"
-do_install[vardeps] += "PHOSPHOR_MAPPER_NAMESPACES"