summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/health/phosphor-health-monitor_git.bb
diff options
context:
space:
mode:
authorJayashree Dhanapal <jayashree-d@hcl.com>2022-09-30 13:06:13 +0300
committerJayashree Dhanapal <jayashree-d@hcl.com>2022-10-03 11:03:45 +0300
commit1ba4d1b1c664adf0f9a9d116d9ea8976f53a39d2 (patch)
tree47c937c523d830aa0f731f2262e446d215409aab /meta-phosphor/recipes-phosphor/health/phosphor-health-monitor_git.bb
parent87f5cff0cfca11f43851cb3d7d49dd96ced7fe03 (diff)
downloadopenbmc-1ba4d1b1c664adf0f9a9d116d9ea8976f53a39d2.tar.xz
phosphor-health-monitor: Add do_install in base recipe.
Added do_install in base recipe for phosphor-health-monitor to copy the json file from WORKDIR to target for monitoring the CPU and Memory usage of BMC. Therefore, this can be removed in each bbappend files. Tested: Tested in Facebook YosemiteV2 platform. Signed-off-by: Jayashree Dhanapal <jayashree-d@hcl.com> Change-Id: I78eed7efb3e0be81a952c4bc3c3ae64579a48f7d
Diffstat (limited to 'meta-phosphor/recipes-phosphor/health/phosphor-health-monitor_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/health/phosphor-health-monitor_git.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/health/phosphor-health-monitor_git.bb b/meta-phosphor/recipes-phosphor/health/phosphor-health-monitor_git.bb
index 4c70253f54..a8aed2c404 100644
--- a/meta-phosphor/recipes-phosphor/health/phosphor-health-monitor_git.bb
+++ b/meta-phosphor/recipes-phosphor/health/phosphor-health-monitor_git.bb
@@ -18,3 +18,10 @@ SYSTEMD_SERVICE:${PN} = "phosphor-health-monitor.service"
inherit meson pkgconfig
inherit systemd
+
+do_install:append() {
+ if [ -e "${WORKDIR}/bmc_health_config.json" ]; then
+ install -d ${D}${sysconfdir}/healthMon
+ install -m 0644 ${WORKDIR}/bmc_health_config.json ${D}${sysconfdir}/healthMon
+ fi
+}